OpenClaw's gateway config mutation guard allowed unsafe model-driven config writes
CVE-2026-45006GHSA-cwj3-vqpp-pmxr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.4.23), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm openclaw
- Affected
- < 2026.4.23
- Fixed in
- 2026.4.23
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-cwj3-vqpp-pmxr lists affected ranges: npm openclaw >=0 <2026.4.23 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cwj3-vqpp-pmxr lists affected ranges: npm openclaw >=0 <2026.4.23
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-45006: 0.49% estimated exploitation activity in the next 30 days; percentile 42.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The agent-facing gateway tool protects config.apply and config.patch with a model-to-operator trust boundary. That guard used a hand-maintained denylist of protected config paths. The config schema outgrew that denylist, leaving sensitive subtrees writable through model-driven gateway config mutations. Impact A prompt-injected or otherwise compromised model running with access to the owner-only gateway tool could persist unsafe config changes that crossed security boundaries. Examples included config paths affecting command execution, network/proxy/TLS behavior, credential forwarding, telemetry or hook endpoints, memory/indexing surfaces, and operator policy controls. These changes could survive restart once written to config. Affected Packages / Versions - Package: openclaw on npm - Affected: versions before 2026.4.23 - Fixed: 2026.4.23 - Latest stable verified fixed: openclaw@2026.4.23, tag v2026.4.23 Fix OpenClaw replaced the denylist with a fail-closed allowlist.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-cwj3-vqpp-pmxr
- Revision 1 · created ·
Published from osv record GHSA-cwj3-vqpp-pmxr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-45006 Advisory: OpenClaw's gateway config mutation guard allowed unsafe model-driven config writes IDs: CVE-2026-45006, GHSA-cwj3-vqpp-pmxr Record: https://patchnext.com/advisories/cve-2026-45006 (revision 2, source checked 26 Oct 2026, 12:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.4.23. A vendor fix does not mean a deployment is fixed. ## Affected components - npm openclaw: affected < 2026.4.23; fixed in 2026.4.23 ## Suggested inspection (read-only) - `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openclaw. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-cwj3-vqpp-pmxr (OSV record GHSA-cwj3-vqpp-pmxr lists affected ranges: npm openclaw >=0 <2026.4.23 (fixed)) - Verified: https://github.com/advisories/GHSA-cwj3-vqpp-pmxr (GitHub-reviewed advisory GHSA-cwj3-vqpp-pmxr lists affected ranges: npm openclaw >=0 <2026.4.23) Commands are suggestions: review each one before running it.
Loading voting…