Skip to content

← Actionable
Medium, CVSS 6.0amended

OpenClaw: Agent gateway config mutations could change protected operator settings

CVE-2026-45001GHSA-7jm2-g593-4qrc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.4.20), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    < 2026.4.20
    Fixed in
    2026.4.20

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.0 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-45001: 0.22% estimated exploitation activity in the next 30 days; percentile 12.32 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Affected Packages / Versions - Package: openclaw (npm) - Affected versions: < 2026.4.20 - Patched version: 2026.4.20 Impact The agent-facing gateway config.patch / config.apply guard did not cover several operator-trusted settings, including sandbox policy, plugin enablement, gateway auth/TLS, hook routing, MCP server configuration, SSRF policy, and filesystem hardening. A prompt-injected model with access to the owner-only gateway tool could persist changes to those settings. This is a model-to-operator guard bypass, not a remote unauthenticated gateway compromise. Severity is medium. Fix OpenClaw now blocks model-driven gateway config mutations for the broader operator-trusted path set and covers per-agent overrides and array-entry patching. Fix commit: - fe30b31a97a917ecc6e92f6c85378b6b20352422 Release Fixed in OpenClaw 2026.4.20.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-7jm2-g593-4qrc

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-7jm2-g593-4qrc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-45001

Advisory: OpenClaw: Agent gateway config mutations could change protected operator settings
IDs: CVE-2026-45001, GHSA-7jm2-g593-4qrc
Record: https://patchnext.com/advisories/cve-2026-45001 (revision 3, source checked 26 Oct 2026, 12:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.4.20. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected < 2026.4.20; fixed in 2026.4.20

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7jm2-g593-4qrc (OSV record GHSA-7jm2-g593-4qrc lists affected ranges: npm openclaw >=0 <2026.4.20 (fixed))
- Verified: https://github.com/advisories/GHSA-7jm2-g593-4qrc (GitHub-reviewed advisory GHSA-7jm2-g593-4qrc lists affected ranges: npm openclaw >=0 <2026.4.20)

Commands are suggestions: review each one before running it.

Loading voting…