OpenClaw: Feishu card actions could misclassify DMs and skip dmPolicy
CVE-2026-44993GHSA-72q8-jcmc-97wx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.4.20), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm openclaw
- Affected
- < 2026.4.20
- Fixed in
- 2026.4.20
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-72q8-jcmc-97wx lists affected ranges: npm openclaw >=0 <2026.4.20 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-72q8-jcmc-97wx lists affected ranges: npm openclaw >=0 <2026.4.20
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-44993: 0.27% estimated exploitation activity in the next 30 days; percentile 18.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected Packages / Versions - Package: openclaw (npm) - Affected versions: < 2026.4.20 - Patched version: 2026.4.20 Impact Feishu card-action callbacks could synthesize a message event with DM conversations classified as group conversations. That skipped dmPolicy enforcement for card actions, so a sender in a Feishu DM could trigger card-action flows that should have been blocked by a restrictive DM policy. The issue is limited to Feishu card-action handling. Severity is medium. Fix OpenClaw now resolves Feishu card-action chat type before dispatch, including API lookup when stored context is unavailable, and avoids falling through to group handling for DMs. Fix commit: - 90979d7c3ef7ec30b9f8aa6963a5e38d2f17d166 Release Fixed in OpenClaw 2026.4.20.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-72q8-jcmc-97wx
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-72q8-jcmc-97wx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44993 Advisory: OpenClaw: Feishu card actions could misclassify DMs and skip dmPolicy IDs: CVE-2026-44993, GHSA-72q8-jcmc-97wx Record: https://patchnext.com/advisories/cve-2026-44993 (revision 3, source checked 26 Oct 2026, 12:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.4.20. A vendor fix does not mean a deployment is fixed. ## Affected components - npm openclaw: affected < 2026.4.20; fixed in 2026.4.20 ## Suggested inspection (read-only) - `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openclaw. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-72q8-jcmc-97wx (OSV record GHSA-72q8-jcmc-97wx lists affected ranges: npm openclaw >=0 <2026.4.20 (fixed)) - Verified: https://github.com/advisories/GHSA-72q8-jcmc-97wx (GitHub-reviewed advisory GHSA-72q8-jcmc-97wx lists affected ranges: npm openclaw >=0 <2026.4.20) Commands are suggestions: review each one before running it.
Loading voting…