OpenClaw: Workspace dotenv MiniMax host override could redirect credentialed requests
CVE-2026-44992GHSA-h2vw-ph2c-jvwf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.4.20), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm openclaw
- Affected
- >= 2026.4.5, < 2026.4.20
- Fixed in
- 2026.4.20
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-h2vw-ph2c-jvwf lists affected ranges: npm openclaw >=2026.4.5 <2026.4.20 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h2vw-ph2c-jvwf lists affected ranges: npm openclaw >=2026.4.5 <2026.4.20
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.8 · CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:P/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N · score source
- EPSS
- CVE-2026-44992: 0.12% estimated exploitation activity in the next 30 days; percentile 1.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected Packages / Versions - Package: openclaw (npm) - Affected versions: = 2026.4.5, < 2026.4.20 - Patched version: 2026.4.20 Impact A malicious workspace .env could set MINIMAXAPIHOST and redirect credentialed MiniMax requests to an attacker-controlled origin, exposing the MiniMax API key in the outbound Authorization header. This requires running OpenClaw from an attacker-controlled workspace. Severity is medium. Fix OpenClaw now blocks MINIMAXAPIHOST from workspace dotenv injection and removes env-driven URL routing from the affected MiniMax request path. Fix commit: - 2f06696579a1ab0cb5bbbbb6a900414a6b2e3cd1 Release Fixed in OpenClaw 2026.4.20.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-h2vw-ph2c-jvwf
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-h2vw-ph2c-jvwf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44992 Advisory: OpenClaw: Workspace dotenv MiniMax host override could redirect credentialed requests IDs: CVE-2026-44992, GHSA-h2vw-ph2c-jvwf Record: https://patchnext.com/advisories/cve-2026-44992 (revision 3, source checked 26 Oct 2026, 12:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.4.20. A vendor fix does not mean a deployment is fixed. ## Affected components - npm openclaw: affected >= 2026.4.5, < 2026.4.20; fixed in 2026.4.20 ## Suggested inspection (read-only) - `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openclaw. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-h2vw-ph2c-jvwf (OSV record GHSA-h2vw-ph2c-jvwf lists affected ranges: npm openclaw >=2026.4.5 <2026.4.20 (fixed)) - Verified: https://github.com/advisories/GHSA-h2vw-ph2c-jvwf (GitHub-reviewed advisory GHSA-h2vw-ph2c-jvwf lists affected ranges: npm openclaw >=2026.4.5 <2026.4.20) Commands are suggestions: review each one before running it.
Loading voting…