OpenClaw: Owner-enforced commands could accept wildcard channel senders as command owners
CVE-2026-44991GHSA-c28g-vh7m-fm7v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.4.21), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm openclaw
- Affected
- <= 2026.4.20
- Fixed in
- 2026.4.21
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-c28g-vh7m-fm7v lists affected ranges: npm openclaw >=0 <2026.4.21 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c28g-vh7m-fm7v lists affected ranges: npm openclaw >=0 <=2026.4.20
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-44991: 0.24% estimated exploitation activity in the next 30 days; percentile 14.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact OpenClaw deployments before 2026.4.21 could treat a non-owner sender as authorized for owner-enforced slash commands when all of the following were true: - a channel plugin declared commands.enforceOwnerForCommands: true; - the channel accepted wildcard inbound senders with allowFrom: [""]; - no explicit commands.ownerAllowFrom was configured. In that state, src/auto-reply/command-auth.ts reused the channel inbound wildcard as part of the command-owner decision. A sender who was not the owner could therefore pass the owner-command gate for commands such as /send, /config, or /debug on the affected channel. The issue is limited to the command-owner authorization axis. It does not by itself grant owner-only tool access, host/sandbox access, or gateway administrator scope. Affected Packages / Versions - Package: openclaw on npm - Affected versions: <= 2026.4.20 - Patched version: 2026.4.21 The latest public release, 2026.4.21, contains the fix. Patches The fix requires a concrete…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-c28g-vh7m-fm7v
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-c28g-vh7m-fm7v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44991 Advisory: OpenClaw: Owner-enforced commands could accept wildcard channel senders as command owners IDs: CVE-2026-44991, GHSA-c28g-vh7m-fm7v Record: https://patchnext.com/advisories/cve-2026-44991 (revision 3, source checked 26 Oct 2026, 12:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.4.21. A vendor fix does not mean a deployment is fixed. ## Affected components - npm openclaw: affected <= 2026.4.20; fixed in 2026.4.21 ## Suggested inspection (read-only) - `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openclaw. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-c28g-vh7m-fm7v (OSV record GHSA-c28g-vh7m-fm7v lists affected ranges: npm openclaw >=0 <2026.4.21 (fixed)) - Verified: https://github.com/advisories/GHSA-c28g-vh7m-fm7v (GitHub-reviewed advisory GHSA-c28g-vh7m-fm7v lists affected ranges: npm openclaw >=0 <=2026.4.20) Commands are suggestions: review each one before running it.
Loading voting…