Skip to content

← Actionable
Critical, CVSS 9.3amended

Apostrophe has default XSS via xmp raw-text passthrough in sanitize-html

CVE-2026-44990GHSA-rpr9-rxv7-x643

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (sanitize-html 2.17.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
EPSS
  • CVE-2026-44990: 0.68% estimated exploitation activity in the next 30 days; percentile 52.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Under the default configuration, sanitize-html can turn attacker-controlled content inside a disallowed xmp element into live HTML or JavaScript. This is a sanitizer bypass in the default disallowedTagsMode: 'discard' path and can lead to stored XSS in applications that render sanitized output back to users. Details In sanitize-html@2.17.3, the default nonTextTags list includes only script, style, textarea, and option in index.js lines 138-142. That means disallowed xmp tags are not treated as "drop the entire contents" tags. Later, in the ontext handler at index.js lines 569-577, the code special-cases textarea and xmp and appends their text content directly to the output without escaping: Because htmlparser2 treats xmp as a raw-text element, markup inside xmp is parsed as text on input but becomes live markup again once it is appended unescaped to the sanitized output. This creates a default sanitizer bypass. For example, a disallowed <xmp wrapper can be used to smuggle…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-rpr9-rxv7-x643

  2. Revision 2 · amended ·

    Amended from osv record GHSA-rpr9-rxv7-x643

  3. Revision 1 · created ·

    Published from ghsa record GHSA-rpr9-rxv7-x643

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44990

Advisory: Apostrophe has default XSS via `xmp` raw-text passthrough in `sanitize-html`
IDs: CVE-2026-44990, GHSA-rpr9-rxv7-x643
Record: https://patchnext.com/advisories/cve-2026-44990 (revision 3, source checked 26 Oct 2026, 12:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: sanitize-html 2.17.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm sanitize-html: affected >= 2.17.3, <= 2.17.3; fixed in 2.17.4

## Suggested inspection (read-only)
- `npm ls sanitize-html --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sanitize-html.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-rpr9-rxv7-x643 (GitHub-reviewed advisory GHSA-rpr9-rxv7-x643 lists affected ranges: npm sanitize-html >=2.17.3 <=2.17.3)
- Verified: https://osv.dev/vulnerability/GHSA-rpr9-rxv7-x643 (OSV record GHSA-rpr9-rxv7-x643 lists affected ranges: npm sanitize-html >=2.17.3 <2.17.4 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…