Skip to content

← Actionable
Medium, CVSS 4.6

CrowdSec LAPI: Denial of Service via Unbounded Gzip Decompression

CVE-2026-44981GHSA-273h-gvwr-c3qj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/crowdsecurity/crowdsec 1.7.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
4.6 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U · score source
EPSS
  • CVE-2026-44981: 0.51% estimated exploitation activity in the next 30 days; percentile 43.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The LAPI router uses gin-contrib/gzip with DefaultDecompressHandle globally (pkg/apiserver/controllers/controller.go). This middleware decompresses incoming request bodies without enforcing a maximum decompressed size. The endpoints /v1/watchers or /v1/watchers/login require no authentication. An attacker can send small gzip-compressed JSON payloads that, when decompressed, result in hundreds of MB of valid JSON occupying server memory. Sending enough requests concurrently will cause LAPI to allocate excessive heap memory, leading the OS to forcibly terminate the process. This vulnerability is not exploitable from the network in default configurations, as LAPI only listens on the loopback interface. If developers' applications are using a multi-server setup, LAPI will be exposed in the network, in which case they are at risk if untrusted IPs can access it. Impact Exploiting this vulnerability will make LAPI unreachable, meaning that bouncers will not be able to fetch new decisions…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-273h-gvwr-c3qj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44981

Advisory: CrowdSec LAPI: Denial of Service via Unbounded Gzip Decompression
IDs: CVE-2026-44981, GHSA-273h-gvwr-c3qj
Record: https://patchnext.com/advisories/cve-2026-44981 (revision 1, source checked 26 Oct 2026, 15:23 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/crowdsecurity/crowdsec 1.7.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/crowdsecurity/crowdsec: affected >= 1.7.0, < 1.7.8; fixed in 1.7.8

## Suggested inspection (read-only)
- Go github.com/crowdsecurity/crowdsec: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/crowdsecurity/crowdsec.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-273h-gvwr-c3qj (GitHub-reviewed advisory GHSA-273h-gvwr-c3qj lists affected ranges: Go github.com/crowdsecurity/crowdsec >=1.7.0 <1.7.8)

Commands are suggestions: review each one before running it.

Loading voting…