@hapi/wreck leaks sensitive Proxy-Authorization header across cross-hostname redirects
CVE-2026-44979GHSA-vhjm-w67q-g75c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@hapi/wreck 18.1.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @hapi/wreck
- Affected
- < 18.1.1
- Fixed in
- 18.1.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vhjm-w67q-g75c lists affected ranges: npm @hapi/wreck >=0 <18.1.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vhjm-w67q-g75c lists affected ranges: npm @hapi/wreck >=0 <18.1.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.3 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N · score source
- EPSS
- CVE-2026-44979: 0.42% estimated exploitation activity in the next 30 days; percentile 36.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact When @hapi/wreck follows a 3xx redirect to a different hostname, only the Authorization and Cookie headers are stripped. The standard credential header Proxy-Authorization is forwarded intact to the redirect target, potentially exposing forward-proxy credentials to a host outside the original trust boundary. Redirect following is opt-in. The redirects option defaults to false (no redirections followed), so applications are only affected if they have explicitly set redirects to a positive integer on the request or via Wreck.defaults({ redirects: ... }). Patches @hapi/wreck 18.1.1 extends the cross-hostname strip set to include proxy-authorization. Upgrade to 18.1.1 or later. Workarounds If upgrading is not immediately possible: - Leave redirects at its default (false) — applications that never enable redirect following are not affected. - If redirects are required, set redirects: 0 when calling endpoints with sensitive headers, or strip Proxy-Authorization from the headers…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-vhjm-w67q-g75c
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-vhjm-w67q-g75c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44979 Advisory: @hapi/wreck leaks sensitive `Proxy-Authorization` header across cross-hostname redirects IDs: CVE-2026-44979, GHSA-vhjm-w67q-g75c Record: https://patchnext.com/advisories/cve-2026-44979 (revision 3, source checked 26 Oct 2026, 12:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @hapi/wreck 18.1.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @hapi/wreck: affected < 18.1.1; fixed in 18.1.1 ## Suggested inspection (read-only) - `npm ls @hapi/wreck --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @hapi/wreck. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-vhjm-w67q-g75c (OSV record GHSA-vhjm-w67q-g75c lists affected ranges: npm @hapi/wreck >=0 <18.1.1 (fixed)) - Verified: https://github.com/advisories/GHSA-vhjm-w67q-g75c (GitHub-reviewed advisory GHSA-vhjm-w67q-g75c lists affected ranges: npm @hapi/wreck >=0 <18.1.1) Commands are suggestions: review each one before running it.
Loading voting…