@hapi/content header parser has a parameter smuggling issue that allows upload-filter bypass via duplicate parameters
CVE-2026-44974GHSA-36hh-x5p5-jgc8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@hapi/content 6.0.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @hapi/content
- Affected
- < 6.0.2
- Fixed in
- 6.0.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-36hh-x5p5-jgc8 lists affected ranges: npm @hapi/content >=0 <6.0.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-36hh-x5p5-jgc8 lists affected ranges: npm @hapi/content >=0 <6.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:H/SA:N · score source
- EPSS
- CVE-2026-44974: 0.47% estimated exploitation activity in the next 30 days; percentile 40.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The two parsers resolved duplicates inconsistently and silently: - Content.disposition() retained the last occurrence of each parameter. - Content.type() retained the first occurrence of charset and boundary. Either behavior creates a parameter-smuggling primitive when another component in the request-processing chain (a WAF, reverse proxy, security filter, or alternate parser) resolves duplicates the opposite way. The primary attack vector is upload filename allowlist bypass: Content-Disposition: form-data; name="file"; filename="safe.txt"; filename="shell.php" Patches The issue has been patched in 6.0.2. Workarounds Pre or post validate headers looking for duplicates. Resources - RFC 6266 §4.1 — Content-Disposition syntax - RFC 7231 §3.1.1.1 — Content-Type syntax - RFC 7230 §3.2.6 — token character set
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-36hh-x5p5-jgc8
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-36hh-x5p5-jgc8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44974 Advisory: @hapi/content header parser has a parameter smuggling issue that allows upload-filter bypass via duplicate parameters IDs: CVE-2026-44974, GHSA-36hh-x5p5-jgc8 Record: https://patchnext.com/advisories/cve-2026-44974 (revision 3, source checked 26 Oct 2026, 12:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @hapi/content 6.0.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @hapi/content: affected < 6.0.2; fixed in 6.0.2 ## Suggested inspection (read-only) - `npm ls @hapi/content --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @hapi/content. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-36hh-x5p5-jgc8 (OSV record GHSA-36hh-x5p5-jgc8 lists affected ranges: npm @hapi/content >=0 <6.0.2 (fixed)) - Verified: https://github.com/advisories/GHSA-36hh-x5p5-jgc8 (GitHub-reviewed advisory GHSA-36hh-x5p5-jgc8 lists affected ranges: npm @hapi/content >=0 <6.0.2) Commands are suggestions: review each one before running it.
Loading voting…