Skip to content

← Actionable
Medium, CVSS 6.3amended

dbt MCP Server has an Argument Injection in dbt CLI Tool Wrappers via node_selection and resource_type Parameters

CVE-2026-44968GHSA-xpww-f6pm-cfhq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (dbt-mcp 1.17.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI dbt-mcp

    Affected
    <= 1.17.0
    Fixed in
    1.17.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.3 · CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-44968: 0.21% estimated exploitation activity in the next 30 days; percentile 10.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Discovered through manual source code review. Verified by PoC execution against a local dbt-mcp v1.15.1 installation. Summary rundbtcommand() in src/dbtmcp/dbtcli/tools.py constructs the dbt subprocess argument list by appending user-supplied MCP tool parameters without sanitization. Two independent injection vectors exist. An MCP client can inject arbitrary dbt global flags — such as --profiles-dir, --project-dir, and --target — by crafting the nodeselection string (Vector 1) or the resourcetype JSON array (Vector 2). Because subprocess.Popen is called with shell=False and a list argument, shell metacharacter injection is not possible; however, this provides no defense against argument list injection (CWE-88), where attacker-controlled tokens are interpreted by the target process as flags rather than values. Details Vector 1 — nodeselection string Affected tools: build, compile, run, test, clone, list, getnodedetailsdev str.split(" ") does not distinguish dbt selector tokens from…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-xpww-f6pm-cfhq

  2. Revision 1 · created ·

    Published from osv record GHSA-xpww-f6pm-cfhq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44968

Advisory: dbt MCP Server has an Argument Injection in dbt CLI Tool Wrappers via node_selection and resource_type Parameters
IDs: CVE-2026-44968, GHSA-xpww-f6pm-cfhq
Record: https://patchnext.com/advisories/cve-2026-44968 (revision 2, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: dbt-mcp 1.17.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI dbt-mcp: affected <= 1.17.0; fixed in 1.17.1

## Suggested inspection (read-only)
- `python -m pip show dbt-mcp`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on dbt-mcp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-xpww-f6pm-cfhq (OSV record GHSA-xpww-f6pm-cfhq lists affected ranges: PyPI dbt-mcp >=0 <1.17.1 (fixed))
- Verified: https://github.com/advisories/GHSA-xpww-f6pm-cfhq (GitHub-reviewed advisory GHSA-xpww-f6pm-cfhq lists affected ranges: PyPI dbt-mcp >=0 <=1.17.0)

Commands are suggestions: review each one before running it.

Loading voting…