Rancher vulnerable to command injection through unsanitized YAML parameter
CVE-2026-44939GHSA-mhc6-2gfq-xx62
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/rancher/rancher 2.14.2, 2.13.6, 2.12.10, 2.11.14, 2.10.12, 0.0.0-20260617231817-2aa77eb283e7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 2.14.0, < 2.14.2>= 2.13.0, < 2.13.6>= 2.12.0, < 2.12.10>= 2.11.0, < 2.11.14>= 2.10.0, < 2.10.12< 0.0.0-20260617231817-2aa77eb283e7
- Fixed in
- 2.11.14, 2.10.12, 2.14.2, 0.0.0-20260617231817-2aa77eb283e7, 2.12.10, 2.13.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mhc6-2gfq-xx62 lists affected ranges: Go github.com/rancher/rancher >=2.14.0 =2.13.0 =2.12.0 =2.11.0 =2.10.0 =0 <0.0.0-20260617231817-2aa77eb283e7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2026-44939: 1.28% estimated exploitation activity in the next 30 days; percentile 70.03 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A critical command injection vulnerability has been identified in the Rancher Manager cluster import endpoint /v3/import/{token}{clusterId}.yaml through unsanitized YAML parameters. This endpoint accepts an authImage query parameter that is rendered without sanitization into a generated Kubernetes manifest template. By including URL-encoded newlines in the parameter value, an attacker can break out of the image: field to inject arbitrary YAML keys and malicious configurations, such as commands to execute malicious containers. Exploitation of this vulnerability requires the following conditions to be met: - Attackers must obtain a valid cluster registration token (these tokens may be exposed, for example, through documentation, screenshots, or insecure communication channels). - The victim’s cluster operator must execute kubectl apply against a maliciously crafted URL. When a victim applies this compromised manifest using kubectl apply, a DaemonSet is deployed with the injected…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-mhc6-2gfq-xx62
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44939 Advisory: Rancher vulnerable to command injection through unsanitized YAML parameter IDs: CVE-2026-44939, GHSA-mhc6-2gfq-xx62 Record: https://patchnext.com/advisories/cve-2026-44939 (revision 1, source checked 26 Oct 2026, 15:28 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/rancher/rancher 2.14.2, 2.13.6, 2.12.10, 2.11.14, 2.10.12, 0.0.0-20260617231817-2aa77eb283e7. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/rancher/rancher: affected >= 2.14.0, < 2.14.2; >= 2.13.0, < 2.13.6; >= 2.12.0, < 2.12.10; >= 2.11.0, < 2.11.14; >= 2.10.0, < 2.10.12; < 0.0.0-20260617231817-2aa77eb283e7; fixed in 2.11.14, 2.10.12, 2.14.2, 0.0.0-20260617231817-2aa77eb283e7, 2.12.10, 2.13.6 ## Suggested inspection (read-only) - Go github.com/rancher/rancher: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/rancher/rancher. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-mhc6-2gfq-xx62 (GitHub-reviewed advisory GHSA-mhc6-2gfq-xx62 lists affected ranges: Go github.com/rancher/rancher >=2.14.0 =2.13.0 =2.12.0 =2.11.0 =2.10.0 =0 <0.0.0-20260617231817-2aa77eb283e7) Commands are suggestions: review each one before running it.
Loading voting…