Skip to content

← Actionable
High, CVSS 7.5

Rancher Fleet has Unauthenticated Webhook: Regex Injection via Unsanitized Repository URL Components

CVE-2026-44937GHSA-jmf4-m7j9-g72r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/rancher/fleet 0.15.2, 0.14.6, 0.13.11, 0.12.15), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/rancher/fleet

    Affected
    >= 0.15.0, < 0.15.2>= 0.14.0, < 0.14.6>= 0.13.0, < 0.13.11>= 0.12.0, < 0.12.15
    Fixed in
    0.12.15, 0.14.6, 0.15.2, 0.13.11

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:N/I:L/A:H
EPSS
  • CVE-2026-44937: 0.42% estimated exploitation activity in the next 30 days; percentile 36.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A vulnerability has been identified in Fleet when the webhook endpoint is configured without a secret; an attacker can forge webhook requests. The attacker doesn't need to know the specific repository or path configured in the GitRepo resource to make Fleet process these requests. An attacker can exploit this vulnerability to cause the following impacts: 1. Trigger continuous repository re-cloning, which increases network traffic and can deplete resources on the management cluster. 2. Downgrade running services to any historical revision available in the remote Git repository. This risk applies if the attacker has read access to the target Git repository and knows its configured path. Please consult the associated MITRE ATT&CK - Technique - T1499.004: Endpoint Denial of Service for further information about this category of attack. Patches To resolve this vulnerability, upgrade Fleet to a patched version. This upgrade version escapes the URL and path to the remote repository…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jmf4-m7j9-g72r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44937

Advisory: Rancher Fleet has Unauthenticated Webhook: Regex Injection via Unsanitized Repository URL Components
IDs: CVE-2026-44937, GHSA-jmf4-m7j9-g72r
Record: https://patchnext.com/advisories/cve-2026-44937 (revision 1, source checked 26 Oct 2026, 15:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/rancher/fleet 0.15.2, 0.14.6, 0.13.11, 0.12.15. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/rancher/fleet: affected >= 0.15.0, < 0.15.2; >= 0.14.0, < 0.14.6; >= 0.13.0, < 0.13.11; >= 0.12.0, < 0.12.15; fixed in 0.12.15, 0.14.6, 0.15.2, 0.13.11

## Suggested inspection (read-only)
- Go github.com/rancher/fleet: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/rancher/fleet.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jmf4-m7j9-g72r (GitHub-reviewed advisory GHSA-jmf4-m7j9-g72r lists affected ranges: Go github.com/rancher/fleet >=0.15.0 =0.14.0 =0.13.0 =0.12.0 <0.12.15)

Commands are suggestions: review each one before running it.

Loading voting…