Skip to content

← Actionable
High, CVSS 7.5

Apache NiFi: Missing authorization when replacing Process Groups with restricted components

CVE-2026-44914GHSA-r2g5-993q-664g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.nifi:nifi-web-api 2.9.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.5 · CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L/S:P/AU:Y/R:U/V:C/RE:L/U:Clear · score source
EPSS
  • CVE-2026-44914: 0.66% estimated exploitation activity in the next 30 days; percentile 51.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Apache NiFi 1.12.0 through 2.9.0 are missing authorization when replacing Process Groups that include extension components with specific Required Permissions based on the Restricted annotation. The Restricted annotation indicates additional privileges required, but framework authorization did not check restricted status when handling requests to replace Process Groups. The missing authorization permits a user with general write access to add components with Restricted status. Apache NiFi installations that do not implement specific authorization for Restricted components are not subject to this vulnerability because the framework enforces write permissions as the security boundary. Upgrading to Apache NiFi 2.9.0 is the recommended mitigation, which removes the implementation of Restricted status authorization from the framework.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-r2g5-993q-664g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44914

Advisory: Apache NiFi: Missing authorization when replacing Process Groups with restricted components
IDs: CVE-2026-44914, GHSA-r2g5-993q-664g
Record: https://patchnext.com/advisories/cve-2026-44914 (revision 1, source checked 26 Oct 2026, 16:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.nifi:nifi-web-api 2.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.nifi:nifi-web-api: affected >= 1.12.0, < 2.9.0; fixed in 2.9.0

## Suggested inspection (read-only)
- Maven org.apache.nifi:nifi-web-api: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.nifi:nifi-web-api.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-r2g5-993q-664g (GitHub-reviewed advisory GHSA-r2g5-993q-664g lists affected ranges: Maven org.apache.nifi:nifi-web-api >=1.12.0 <2.9.0)

Commands are suggestions: review each one before running it.

Loading voting…