Skip to content

← Actionable
Medium, CVSS 5.2

Apache NiFi: Improper Escaping of Table Names in CaptureChangeMySQL

CVE-2026-44913GHSA-chxj-gxww-q98w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.nifi:nifi-cdc-mysql-processors 2.10.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.2 · CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H/S:P/AU:Y/R:U/V:C/RE:L/U:Clear · score source
EPSS
  • CVE-2026-44913: 0.65% estimated exploitation activity in the next 30 days; percentile 51.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Improper escaping of database table names in the CaptureChangeMySQL Processor included with Apache NiFi 1.2.0 through 2.9.0 allows for injecting SQL commands using crafted naming. Manual quoted boundaries added in Apache NiFi 1.8.0 narrowed the scope of potential injection options, but did not cover additional strategies. Apache NiFi installations that do not use the CaptureChangeMySQL Processor are not subject to this vulnerability. Upgrading to Apache NiFi 2.10.0 is the recommended mitigation, which incorporates more robust identifier escaping.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-chxj-gxww-q98w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44913

Advisory: Apache NiFi: Improper Escaping of Table Names in CaptureChangeMySQL
IDs: CVE-2026-44913, GHSA-chxj-gxww-q98w
Record: https://patchnext.com/advisories/cve-2026-44913 (revision 1, source checked 26 Oct 2026, 16:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.nifi:nifi-cdc-mysql-processors 2.10.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.nifi:nifi-cdc-mysql-processors: affected >= 1.2.0, < 2.10.0; fixed in 2.10.0

## Suggested inspection (read-only)
- Maven org.apache.nifi:nifi-cdc-mysql-processors: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.nifi:nifi-cdc-mysql-processors.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-chxj-gxww-q98w (GitHub-reviewed advisory GHSA-chxj-gxww-q98w lists affected ranges: Maven org.apache.nifi:nifi-cdc-mysql-processors >=1.2.0 <2.10.0)

Commands are suggestions: review each one before running it.

Loading voting…