Skip to content

← Actionable
High, CVSS 7.5amended

react-server-dom: Denial of Service in Server Functions

CVE-2026-44907GHSA-wx67-qw84-cm4g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (react-server-dom-turbopack 19.2.8, 19.1.9, 19.0.8; react-server-dom-parcel 19.2.8, 19.1.9; react-server-dom-webpack 19.2.8, 19.1.9, 19.0.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-44907: 0.60% estimated exploitation activity in the next 30 days; percentile 48.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A denial of service vulnerability could be triggered by sending specially crafted HTTP requests to server function endpoints, this could lead to out-of-memory exceptions or excessive CPU usage. We recommend updating immediately. The vulnerability exists in versions 19.0.0 through 19.0.7, 19.1.0 through 19.1.8, and 19.2.0 through 19.2.7 of: - react-server-dom-webpack - react-server-dom-parcel - react-server-dom-turbopack Patches Fixes were back ported to versions 19.0.8, 19.1.9, and 19.2.8. If you are using any of the above packages please upgrade to any of the fixed versions immediately. If your app’s React code does not use a server, your app is not affected by this vulnerability. If your app does not use a framework, bundler, or bundler plugin that supports React Server Components, your app is not affected by this vulnerability.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-wx67-qw84-cm4g

  2. Revision 1 · created ·

    Published from osv record GHSA-wx67-qw84-cm4g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44907

Advisory: react-server-dom: Denial of Service in Server Functions
IDs: CVE-2026-44907, GHSA-wx67-qw84-cm4g
Record: https://patchnext.com/advisories/cve-2026-44907 (revision 2, source checked 26 Oct 2026, 12:58 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: react-server-dom-turbopack 19.2.8, 19.1.9, 19.0.8; react-server-dom-parcel 19.2.8, 19.1.9; react-server-dom-webpack 19.2.8, 19.1.9, 19.0.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm react-server-dom-turbopack: affected >= 19.0.0, < 19.0.8; >= 19.1.0, < 19.1.9; >= 19.2.0, < 19.2.8; fixed in 19.2.8, 19.0.8, 19.1.9
- npm react-server-dom-parcel: affected >= 19.1.0, < 19.1.9; >= 19.2.0, < 19.2.8; fixed in 19.2.8, 19.1.9
- npm react-server-dom-webpack: affected >= 19.0.0, < 19.0.8; >= 19.1.0, < 19.1.9; >= 19.2.0, < 19.2.8; fixed in 19.2.8, 19.0.8, 19.1.9

## Suggested inspection (read-only)
- `npm ls react-server-dom-turbopack --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls react-server-dom-parcel --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls react-server-dom-webpack --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on react-server-dom-turbopack, react-server-dom-parcel, react-server-dom-webpack.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-wx67-qw84-cm4g (OSV record GHSA-wx67-qw84-cm4g lists affected ranges: npm react-server-dom-webpack >=19.0.0 =19.1.0 =19.2.0 =19.0.0 =19.1.0 =19.2.0 =19.1.0 =19.2.0 <19.2.8 (fixed))
- Verified: https://github.com/advisories/GHSA-wx67-qw84-cm4g (GitHub-reviewed advisory GHSA-wx67-qw84-cm4g lists affected ranges: npm react-server-dom-webpack >=19.0.0 =19.1.0 =19.2.0 =19.0.0 =19.1.0 =19.2.0 =19.1.0 =19.2.0 <19.2.8)

Commands are suggestions: review each one before running it.

Loading voting…