Skip to content

← Actionable
High, CVSS 7.5amended

Prometheus exporter process crash via malformed HTTP request

CVE-2026-44902GHSA-q7rr-3cgh-j5r3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@opentelemetry/exporter-prometheus 0.217.0; @opentelemetry/auto-instrumentations-node 0.75.0; @opentelemetry/sdk-node 0.217.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-44902: 0.47% estimated exploitation activity in the next 30 days; percentile 40.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A single malformed HTTP request crashes any Node.js process running the OpenTelemetry JS Prometheus exporter. The metrics endpoint (default 0.0.0.0:9464) has no error handling around URL parsing, so a request with an invalid URI causes an uncaught TypeError that terminates the process. You are affected by this vulnerability if either of the following apply to your application: you directly use @opentelemetry/exporter-prometheus in your code through its built-in server. your OTELMETRICSEXPORTER environment variable includes prometheus AND you use @opentelemetry/sdk-node you use @opentelemetry/auto-instrumentations-node via --require @opentelemetry/auto-instrumentations-node/register/--import @opentelemetry/auto-instrumentations-node/register Impact Denial of service. Any application using the OpenTelemetry Prometheus exporter’s built-in server can be crashed by a single unauthenticated network packet sent to the metrics port. No authentication, special privileges, or prior…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-q7rr-3cgh-j5r3

  2. Revision 1 · created ·

    Published from osv record GHSA-q7rr-3cgh-j5r3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44902

Advisory: Prometheus exporter process crash via malformed HTTP request
IDs: CVE-2026-44902, GHSA-q7rr-3cgh-j5r3
Record: https://patchnext.com/advisories/cve-2026-44902 (revision 2, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @opentelemetry/exporter-prometheus 0.217.0; @opentelemetry/auto-instrumentations-node 0.75.0; @opentelemetry/sdk-node 0.217.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @opentelemetry/exporter-prometheus: affected < 0.217.0; fixed in 0.217.0
- npm @opentelemetry/auto-instrumentations-node: affected >= 0.55.0, < 0.75.0; fixed in 0.75.0
- npm @opentelemetry/sdk-node: affected >= 0.57.0, < 0.217.0; fixed in 0.217.0

## Suggested inspection (read-only)
- `npm ls @opentelemetry/exporter-prometheus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @opentelemetry/auto-instrumentations-node --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @opentelemetry/sdk-node --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @opentelemetry/exporter-prometheus, @opentelemetry/auto-instrumentations-node, @opentelemetry/sdk-node.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-q7rr-3cgh-j5r3 (OSV record GHSA-q7rr-3cgh-j5r3 lists affected ranges: npm @opentelemetry/exporter-prometheus >=0 =0.57.0 =0.55.0 <0.75.0 (fixed))
- Verified: https://github.com/advisories/GHSA-q7rr-3cgh-j5r3 (GitHub-reviewed advisory GHSA-q7rr-3cgh-j5r3 lists affected ranges: npm @opentelemetry/exporter-prometheus >=0 =0.57.0 =0.55.0 <0.75.0)

Commands are suggestions: review each one before running it.

Loading voting…