Skip to content

← Actionable
Medium, CVSS 4.7amended

Mistune Image Directive CSS Injection Vulnerability

CVE-2026-44899GHSA-ccfx-mfmx-2fx9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mistune 3.2.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI mistune

    Affected
    >= 3.2.0, <= 3.2.0
    Fixed in
    3.2.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.7 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:N/A:N
EPSS
  • CVE-2026-44899: 0.23% estimated exploitation activity in the next 30 days; percentile 13.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The Image directive plugin validates the :width: and :height: options with a regex compiled as numre = re.compile(r"^\d+(?:\.\d)?"). This pattern is applied via re.match() (which anchors only at the start of the string, not the end). Any value that begins with one or more digits passes validation, regardless of what follows. When the validated value is not a plain integer, renderblockimage() inserts it directly into a style="width:...;" or style="height:...;" attribute. Because the value was accepted by the prefix-only regex, any CSS after the leading digits reaches the style= attribute verbatim and without escaping. An attacker can therefore inject an arbitrary chain of CSS properties — including position:fixed, background-color, z-index, outline, and opacity — using nothing more than a single :width: option in a fenced image directive. The resulting element can visually cover the entire browser viewport, enabling full-page phishing overlays and UI redressing attacks.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-ccfx-mfmx-2fx9

  2. Revision 1 · created ·

    Published from osv record GHSA-ccfx-mfmx-2fx9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44899

Advisory: Mistune Image Directive CSS Injection Vulnerability
IDs: CVE-2026-44899, GHSA-ccfx-mfmx-2fx9
Record: https://patchnext.com/advisories/cve-2026-44899 (revision 2, source checked 26 Oct 2026, 13:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mistune 3.2.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI mistune: affected >= 3.2.0, <= 3.2.0; fixed in 3.2.1

## Suggested inspection (read-only)
- `python -m pip show mistune`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mistune.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-ccfx-mfmx-2fx9 (OSV record GHSA-ccfx-mfmx-2fx9 lists affected ranges: PyPI mistune >=3.2.0 <3.2.1 (fixed))
- Verified: https://github.com/advisories/GHSA-ccfx-mfmx-2fx9 (GitHub-reviewed advisory GHSA-ccfx-mfmx-2fx9 lists affected ranges: PyPI mistune >=3.2.0 <=3.2.0)

Commands are suggestions: review each one before running it.

Loading voting…