Netty's Default QUIC token handler accepts any client-supplied token
CVE-2026-44894GHSA-cmm3-54f8-px4j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.netty:netty-codec-classes-quic 4.2.15.Final), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven io.netty:netty-codec-classes-quic
- Affected
- >= 4.2.0.Final, <= 4.2.14.Final
- Fixed in
- 4.2.15.Final
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cmm3-54f8-px4j lists affected ranges: Maven io.netty:netty-codec-classes-quic >=4.2.0.Final <=4.2.14.Final
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2026-44894: 0.14% estimated exploitation activity in the next 30 days; percentile 3.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
NoQuicTokenHandler is the tokenHandler used when the application does not set one. Its writeToken() returns false (server will not send Retry — acceptable), but validateToken() unconditionally return 0. In QuicheQuicServerCodec.handlePacket(), a non-negative return from validateToken() is interpreted as 'token is valid, ODCID starts at offset 0', causing the server to call quicheaccept as if the client's address had been validated by a Retry round-trip. Per RFC 9000 §8.1, a validated address lifts the 3× anti-amplification send limit. Thus any attacker who includes ANY non-empty token bytes in an Initial packet — with a spoofed victim source IP — causes the Netty server to treat the victim as validated and reflect full-size handshake flights (certificates, etc.) toward it without the 3× cap. The correct 'no token handler' semantics would be to return -1 (invalid) so the normal un-validated path and amplification limit apply.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-cmm3-54f8-px4j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44894 Advisory: Netty's Default QUIC token handler accepts any client-supplied token IDs: CVE-2026-44894, GHSA-cmm3-54f8-px4j Record: https://patchnext.com/advisories/cve-2026-44894 (revision 1, source checked 26 Oct 2026, 16:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: io.netty:netty-codec-classes-quic 4.2.15.Final. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven io.netty:netty-codec-classes-quic: affected >= 4.2.0.Final, <= 4.2.14.Final; fixed in 4.2.15.Final ## Suggested inspection (read-only) - Maven io.netty:netty-codec-classes-quic: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on io.netty:netty-codec-classes-quic. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-cmm3-54f8-px4j (GitHub-reviewed advisory GHSA-cmm3-54f8-px4j lists affected ranges: Maven io.netty:netty-codec-classes-quic >=4.2.0.Final <=4.2.14.Final) Commands are suggestions: review each one before running it.
Loading voting…