Netty: HAProxy SSL TLV parsing leaks retained slice on invalid TLV length
CVE-2026-44893GHSA-cc37-9q2j-3hfv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.netty:netty-codec-haproxy 4.2.15.Final, 4.1.135.Final), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven io.netty:netty-codec-haproxy
- Affected
- >= 4.2.0.Final, <= 4.2.14.Final<= 4.1.134.Final
- Fixed in
- 4.2.15.Final, 4.1.135.Final
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cc37-9q2j-3hfv lists affected ranges: Maven io.netty:netty-codec-haproxy >=4.2.0.Final =0 <=4.1.134.Final
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-44893: 0.62% estimated exploitation activity in the next 30 days; percentile 49.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
When decoding a PP2TYPESSL TLV, HAProxyMessage.readNextTLV() first calls header.retainedSlice(header.readerIndex(), length) and only then reads the 1-byte client field and 4-byte verify field. If the attacker sets the TLV length below 5, the subsequent readByte/readInt throws IndexOutOfBoundsException. HAProxyMessageDecoder only catches HAProxyProtocolException around this call, so the IOOBE propagates and the retained slice on the pooled cumulation buffer is never released.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-cc37-9q2j-3hfv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44893 Advisory: Netty: HAProxy SSL TLV parsing leaks retained slice on invalid TLV length IDs: CVE-2026-44893, GHSA-cc37-9q2j-3hfv Record: https://patchnext.com/advisories/cve-2026-44893 (revision 1, source checked 26 Oct 2026, 16:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: io.netty:netty-codec-haproxy 4.2.15.Final, 4.1.135.Final. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven io.netty:netty-codec-haproxy: affected >= 4.2.0.Final, <= 4.2.14.Final; <= 4.1.134.Final; fixed in 4.2.15.Final, 4.1.135.Final ## Suggested inspection (read-only) - Maven io.netty:netty-codec-haproxy: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on io.netty:netty-codec-haproxy. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-cc37-9q2j-3hfv (GitHub-reviewed advisory GHSA-cc37-9q2j-3hfv lists affected ranges: Maven io.netty:netty-codec-haproxy >=4.2.0.Final =0 <=4.1.134.Final) Commands are suggestions: review each one before running it.
Loading voting…