Portainer has an endpoint security bypass via Swarm service create/update
CVE-2026-44849GHSA-5fxq-qcf3-244w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/portainer/portainer 2.41.0, 2.39.2, 2.33.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/portainer/portainer
- Affected
- >= 2.33.0, < 2.33.8>= 2.39.0, < 2.39.2>= 2.40.0, < 2.41.0
- Fixed in
- 2.39.2, 2.33.8, 2.41.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5fxq-qcf3-244w lists affected ranges: Go github.com/portainer/portainer >=2.33.0 =2.39.0 =2.40.0 <2.41.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2026-44849: 0.43% estimated exploitation activity in the next 30 days; percentile 36.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Portainer enforces seven EndpointSecuritySettings restrictions that administrators configure to restrict the container configurations non-admin users can launch: privileged mode, host PID namespace, device mapping, capabilities, sysctls, security-opt (Seccomp / AppArmor), and bind mounts. The vulnerability is exposed when a non-admin Portainer user (Standard User role, or any role granted endpoint-level access) has been given access to a Docker Swarm endpoint via Portainer RBAC. Admins and users without Swarm endpoint access are not affected. These restrictions are enforced on the standard container creation path, but several of them are not applied on the Docker Swarm service API: - POST /services/create — 1 of 7 checks applied. CapabilityAdd, CapabilityDrop, Sysctls, and Privileges (Seccomp / AppArmor) are not parsed from the request body and are forwarded to the Docker daemon without validation. - POST /services/{id}/update — 0 of 7 checks applied. The route dispatches to…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5fxq-qcf3-244w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44849 Advisory: Portainer has an endpoint security bypass via Swarm service create/update IDs: CVE-2026-44849, GHSA-5fxq-qcf3-244w Record: https://patchnext.com/advisories/cve-2026-44849 (revision 1, source checked 26 Oct 2026, 15:23 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/portainer/portainer 2.41.0, 2.39.2, 2.33.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/portainer/portainer: affected >= 2.33.0, < 2.33.8; >= 2.39.0, < 2.39.2; >= 2.40.0, < 2.41.0; fixed in 2.39.2, 2.33.8, 2.41.0 ## Suggested inspection (read-only) - Go github.com/portainer/portainer: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/portainer/portainer. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5fxq-qcf3-244w (GitHub-reviewed advisory GHSA-5fxq-qcf3-244w lists affected ranges: Go github.com/portainer/portainer >=2.33.0 =2.39.0 =2.40.0 <2.41.0) Commands are suggestions: review each one before running it.
Loading voting…