LangChain vulnerable to unsafe deserialization of attacker-controlled objects through overly broad load() allowlists
CVE-2026-44843GHSA-pjwx-r37v-7724
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (langchain-core 1.3.3, 0.3.85), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI langchain-core
- Affected
- >= 1.0.0, <= 1.3.2<= 0.3.84
- Fixed in
- 0.3.85, 1.3.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pjwx-r37v-7724 lists affected ranges: PyPI langchain-core >=1.0.0 =0 <0.3.85 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pjwx-r37v-7724 lists affected ranges: PyPI langchain-core >=1.0.0 =0 <=0.3.84
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
- EPSS
- CVE-2026-44843: 0.41% estimated exploitation activity in the next 30 days; percentile 34.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
LangChain contains older runtime code paths that deserialize run inputs, run outputs, or other application-controlled payloads using overly broad object allowlists. These paths may call load() with allowedobjects="all". This does not enable arbitrary Python object deserialization, but it does allow any trusted LangChain-serializable object to be revived, which is broader than these runtime paths require. As a result, attacker-supplied LangChain serialized constructor dictionaries may cause trusted runtime paths to instantiate classes with untrusted constructor arguments. Applications are exposed only when all of the following are true: 1. The application accepts untrusted structured input, such as JSON, from a user or network request. 2. The application does not validate or canonicalize that input into an inert schema before invoking LangChain. 3. Attacker-controlled nested dictionaries or lists are preserved in LangChain run inputs or outputs. 4. The application uses an affected API…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-pjwx-r37v-7724
- Revision 1 · created ·
Published from osv record GHSA-pjwx-r37v-7724
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44843 Advisory: LangChain vulnerable to unsafe deserialization of attacker-controlled objects through overly broad `load()` allowlists IDs: CVE-2026-44843, GHSA-pjwx-r37v-7724 Record: https://patchnext.com/advisories/cve-2026-44843 (revision 2, source checked 26 Oct 2026, 13:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: langchain-core 1.3.3, 0.3.85. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI langchain-core: affected >= 1.0.0, <= 1.3.2; <= 0.3.84; fixed in 0.3.85, 1.3.3 ## Suggested inspection (read-only) - `python -m pip show langchain-core`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on langchain-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pjwx-r37v-7724 (OSV record GHSA-pjwx-r37v-7724 lists affected ranges: PyPI langchain-core >=1.0.0 =0 <0.3.85 (fixed)) - Verified: https://github.com/advisories/GHSA-pjwx-r37v-7724 (GitHub-reviewed advisory GHSA-pjwx-r37v-7724 lists affected ranges: PyPI langchain-core >=1.0.0 =0 <=0.3.84) Commands are suggestions: review each one before running it.
Loading voting…