Snipe-IT has Privilege Escalation via API Permissions Assignment
CVE-2026-44832GHSA-hq28-crg7-95pr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (snipe/snipe-it 8.4.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist snipe/snipe-it
- Affected
- < 8.4.1
- Fixed in
- 8.4.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hq28-crg7-95pr lists affected ranges: Packagist snipe/snipe-it >=0 <8.4.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-44832: 0.32% estimated exploitation activity in the next 30 days; percentile 24.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An authenticated user with only users.edit permission can escalate their own privileges to admin by sending a PATCH request to /api/v1/users/{id} with permissions[admin]=1. The API controller only strips the superuser key from the permissions array, allowing admin and all other permission keys to be set by any user who can update users. Patches Patched in https://github.com/grokability/snipe-it/commit/ce18ff669ceb0f0349749fd5d11c1d3d40b10569, fix was released in v8.4.1 Workarounds None.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-hq28-crg7-95pr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44832 Advisory: Snipe-IT has Privilege Escalation via API Permissions Assignment IDs: CVE-2026-44832, GHSA-hq28-crg7-95pr Record: https://patchnext.com/advisories/cve-2026-44832 (revision 1, source checked 26 Oct 2026, 14:49 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: snipe/snipe-it 8.4.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist snipe/snipe-it: affected < 8.4.1; fixed in 8.4.1 ## Suggested inspection (read-only) - Packagist snipe/snipe-it: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on snipe/snipe-it. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hq28-crg7-95pr (GitHub-reviewed advisory GHSA-hq28-crg7-95pr lists affected ranges: Packagist snipe/snipe-it >=0 <8.4.1) Commands are suggestions: review each one before running it.
Loading voting…