Skip to content

← Actionable
High, CVSS 8.1amended

Apache Solr has hardcoded credentials in the Basic Authentication setup tool

CVE-2026-44825GHSA-qhr7-h655-pw6r

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven org.apache.solr:solr-core

    Affected
    >= 9.4.0, <= 9.10.1>= 10.0.0, <= 10.0.0
    Fixed in
    no fixed version recorded
  • Bitnami solr

    Affected
    >= 9.4.0, < 10.1.0
    Fixed in
    10.1.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-44825: 3.92% estimated exploitation activity in the next 30 days; percentile 90.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Hardcoded credentials in the Basic Authentication setup tool (bin/solr auth enable) in Apache Solr versions 9.4.0 through 9.10.1 and 10.0.0 allows a remote attacker to gain full administrative access to the cluster via publicly known default credentials installed silently alongside the user-specified account. As an immediate workaround without upgrading, delete the template users (superadmin, admin, search, index) from security.json or change their passwords. The future, not yet released, versions 9.11.0 and 10.1.0 will not be vulnerable, and it will be enough to upgrade to solve the issue. Not affected: Clusters where bin/solr auth enable was not used to bootstrap BasicAuth Clusters where template users have been assigned strong passwords after bootstrap

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record BIT-solr-2026-44825

  2. Revision 1 · created ·

    Published from ghsa record GHSA-qhr7-h655-pw6r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44825

Advisory: Apache Solr has hardcoded credentials in the Basic Authentication setup tool
IDs: CVE-2026-44825, GHSA-qhr7-h655-pw6r
Record: https://patchnext.com/advisories/cve-2026-44825 (revision 2, source checked 31 Oct 2026, 07:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: solr 10.1.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.solr:solr-core: affected >= 9.4.0, <= 9.10.1; >= 10.0.0, <= 10.0.0
- Bitnami solr: affected >= 9.4.0, < 10.1.0; fixed in 10.1.0

## Suggested inspection (read-only)
- Maven org.apache.solr:solr-core: check the installed version with your package manager.
- Bitnami solr: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.solr:solr-core, solr.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qhr7-h655-pw6r (GitHub-reviewed advisory GHSA-qhr7-h655-pw6r lists affected ranges: Maven org.apache.solr:solr-core >=9.4.0 =10.0.0 <=10.0.0)
- Verified: https://osv.dev/vulnerability/BIT-solr-2026-44825 (OSV record BIT-solr-2026-44825 lists affected ranges: Bitnami solr >=9.4.0 <10.1.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…