Skip to content

← Actionable
High, CVSS 8.5

Spinnaker has non-safe yaml deserialization, allowing RCE when using specific types

CVE-2026-44795GHSA-c8q4-9h32-2ww8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.spinnaker.rosco:rosco-core 2026.0.3, 2025.4.4, 2025.3.3; io.spinnaker.orca:orca-core 2026.0.3, 2025.4.4, 2025.3.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-c8q4-9h32-2ww8 lists affected ranges: Maven io.spinnaker.rosco:rosco-core >=0 =2025.4.0 =2026.0.0 =0 =2025.4.0 =2026.0.0 <2026.0.3

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:H/A:N
EPSS
  • CVE-2026-44795: 1.01% estimated exploitation activity in the next 30 days; percentile 63.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact There's an unsafe YAML processing vulnerability that bypasses safe deserialization. This impacts users when when performing: CloudFormation deployments CloudFoundry Baking The usage of a non-safe constructor use allows arbitrary loading of Java classes leading to RCE. Patches 2025.3.3, 2026.0.3 and 2025.4.4. Workarounds Disable the CloudFormation system and cloudfoundry baking operations. Resources Join Spinnaker on Slack for more information!

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-c8q4-9h32-2ww8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44795

Advisory: Spinnaker has non-safe yaml deserialization, allowing RCE when using specific types
IDs: CVE-2026-44795, GHSA-c8q4-9h32-2ww8
Record: https://patchnext.com/advisories/cve-2026-44795 (revision 1, source checked 26 Oct 2026, 16:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: io.spinnaker.rosco:rosco-core 2026.0.3, 2025.4.4, 2025.3.3; io.spinnaker.orca:orca-core 2026.0.3, 2025.4.4, 2025.3.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven io.spinnaker.rosco:rosco-core: affected < 2025.3.3; >= 2025.4.0, < 2025.4.4; >= 2026.0.0, < 2026.0.3; fixed in 2025.3.3, 2026.0.3, 2025.4.4
- Maven io.spinnaker.orca:orca-core: affected < 2025.3.3; >= 2025.4.0, < 2025.4.4; >= 2026.0.0, < 2026.0.3; fixed in 2025.3.3, 2026.0.3, 2025.4.4

## Suggested inspection (read-only)
- Maven io.spinnaker.rosco:rosco-core: check the installed version with your package manager.
- Maven io.spinnaker.orca:orca-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on io.spinnaker.rosco:rosco-core, io.spinnaker.orca:orca-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-c8q4-9h32-2ww8 (GitHub-reviewed advisory GHSA-c8q4-9h32-2ww8 lists affected ranges: Maven io.spinnaker.rosco:rosco-core >=0 =2025.4.0 =2026.0.0 =0 =2025.4.0 =2026.0.0 <2026.0.3)

Commands are suggestions: review each one before running it.

Loading voting…