n8n Has a Source Control Pull SQL Injection
CVE-2026-44792GHSA-mhrx-qhrj-673w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 2.21.1, 2.20.7, 1.123.43), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm n8n
- Affected
- < 1.123.43>= 2.21.0, < 2.21.1>= 2.0.0-rc.0, < 2.20.7
- Fixed in
- 1.123.43, 2.20.7, 2.21.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mhrx-qhrj-673w lists affected ranges: npm n8n >=0 =2.21.0 =2.0.0-rc.0 <2.20.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mhrx-qhrj-673w lists affected ranges: npm n8n >=0 =2.21.0 =2.0.0-rc.0 <2.20.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.9 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2026-44792: 0.39% estimated exploitation activity in the next 30 days; percentile 32.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An attacker with write access to the git repository connected to an n8n Source Control configuration could commit a malicious Data Table JSON file containing a crafted column name. When an administrator performed a Source Control Pull, n8n imported the file and could lead to SQL injection on the internal PostgreSQL instance. Exploitation requires all of the following conditions: - The n8n instance uses PostgreSQL as its database backend. - The Source Control feature is enabled and connected to a repository the attacker can write to. - An administrator triggers a Source Control Pull. Patches The issue has been fixed in n8n version 1.123.43, 2.20.7, and 2.21.1. Users should upgrade to this version or later to remediate the vulnerability. Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: - Disable the Source Control feature if it is not actively required. - Restrict write access to the connected git…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-mhrx-qhrj-673w
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-mhrx-qhrj-673w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44792 Advisory: n8n Has a Source Control Pull SQL Injection IDs: CVE-2026-44792, GHSA-mhrx-qhrj-673w Record: https://patchnext.com/advisories/cve-2026-44792 (revision 3, source checked 26 Oct 2026, 12:57 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: n8n 2.21.1, 2.20.7, 1.123.43. A vendor fix does not mean a deployment is fixed. ## Affected components - npm n8n: affected < 1.123.43; >= 2.21.0, < 2.21.1; >= 2.0.0-rc.0, < 2.20.7; fixed in 1.123.43, 2.20.7, 2.21.1 ## Suggested inspection (read-only) - `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on n8n. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mhrx-qhrj-673w (OSV record GHSA-mhrx-qhrj-673w lists affected ranges: npm n8n >=0 =2.21.0 =2.0.0-rc.0 <2.20.7 (fixed)) - Verified: https://github.com/advisories/GHSA-mhrx-qhrj-673w (GitHub-reviewed advisory GHSA-mhrx-qhrj-673w lists affected ranges: npm n8n >=0 =2.21.0 =2.0.0-rc.0 <2.20.7) Commands are suggestions: review each one before running it.
Loading voting…