Skip to content

← Actionable
Critical, CVSS 9.4amended

n8n Has an Arbitrary File Read via Git Node

CVE-2026-44790GHSA-57g9-58c2-xjg3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 2.22.1, 2.20.7, 1.123.43), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm n8n

    Affected
    < 1.123.43>= 2.21.0, < 2.22.1>= 2.0.0-rc.0, < 2.20.7
    Fixed in
    2.22.1, 1.123.43, 2.20.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2026-44790: 0.53% estimated exploitation activity in the next 30 days; percentile 44.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An authenticated user with permission to create or modify workflows could inject CLI flags on the Git node's Push operation allowing an attacker to read arbitrary files from the n8n server potentially leading to full compromise. Patches The issue has been fixed in n8n versions 1.123.43, 2.20.7, and 2.22.1. Users should upgrade to one of these versions or later to remediate the vulnerability. Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: - Limit workflow creation and editing permissions to fully trusted users only. - Disable the Git node by adding n8n-nodes-base.git to the NODESEXCLUDE environment variable. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures. --- n8n has adopted CVSS 4.0 as primary score for all security advisories. CVSS 3.1 vector strings are provided for backwards compatibility. CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-57g9-58c2-xjg3

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-57g9-58c2-xjg3

  4. Revision 1 · created ·

    Published from ghsa record GHSA-57g9-58c2-xjg3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44790

Advisory: n8n Has an Arbitrary File Read via Git Node
IDs: CVE-2026-44790, GHSA-57g9-58c2-xjg3
Record: https://patchnext.com/advisories/cve-2026-44790 (revision 4, source checked 26 Oct 2026, 12:57 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: n8n 2.22.1, 2.20.7, 1.123.43. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm n8n: affected < 1.123.43; >= 2.21.0, < 2.22.1; >= 2.0.0-rc.0, < 2.20.7; fixed in 2.22.1, 1.123.43, 2.20.7

## Suggested inspection (read-only)
- `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on n8n.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-57g9-58c2-xjg3 (GitHub-reviewed advisory GHSA-57g9-58c2-xjg3 lists affected ranges: npm n8n >=0 =2.21.0 =2.0.0-rc.0 <2.20.7)
- Verified: https://osv.dev/vulnerability/GHSA-57g9-58c2-xjg3 (OSV record GHSA-57g9-58c2-xjg3 lists affected ranges: npm n8n >=0 =2.21.0 =2.0.0-rc.0 <2.20.7 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…