Pimcore Admin Classic Bundle Vulnerable to SQL Injection in Translation Grid Date Filter via Unsanitized Property Parameter
CVE-2026-44741GHSA-h4ph-crvj-9h92
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pimcore/admin-ui-classic-bundle 2.3.6, 1.7.18), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist pimcore/admin-ui-classic-bundle
- Affected
- >= 2.0.0-RC1, <= 2.3.5< 1.7.18
- Fixed in
- 1.7.18, 2.3.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h4ph-crvj-9h92 lists affected ranges: Packagist pimcore/admin-ui-classic-bundle >=2.0.0-RC1 =0 <1.7.18
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-44741: 0.50% estimated exploitation activity in the next 30 days; percentile 42.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
GitHub Security Advisory Draft — GM-369 Summary SQL injection in Pimcore's translation grid date filter — the user-supplied property field from the filter JSON is interpolated directly into a UNIXTIMESTAMP(DATE(FROMUNIXTIME(...))) SQL expression without parameterization or allowlist validation. Severity CVSS 3.1: 8.8 (High) — AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H Affected Component - Package: pimcore/admin-ui-classic-bundle - File: src/Controller/Admin/TranslationController.php - Lines: 565 (input), 569 (inadequate sanitization), 593 (injection point) - Endpoint: POST /admin/translation/translations Description The translation grid endpoint processes JSON filter parameters. When a filter has type: "date", the property field is extracted and used to construct a SQL expression: The strreplace('--', '') sanitization is trivially bypassable (use // comments or ----). In non-language mode, $fieldname is concatenated directly into the SQL condition without quoting or parameterization. Impact…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-h4ph-crvj-9h92
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44741 Advisory: Pimcore Admin Classic Bundle Vulnerable to SQL Injection in Translation Grid Date Filter via Unsanitized Property Parameter IDs: CVE-2026-44741, GHSA-h4ph-crvj-9h92 Record: https://patchnext.com/advisories/cve-2026-44741 (revision 1, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pimcore/admin-ui-classic-bundle 2.3.6, 1.7.18. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist pimcore/admin-ui-classic-bundle: affected >= 2.0.0-RC1, <= 2.3.5; < 1.7.18; fixed in 1.7.18, 2.3.6 ## Suggested inspection (read-only) - Packagist pimcore/admin-ui-classic-bundle: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pimcore/admin-ui-classic-bundle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-h4ph-crvj-9h92 (GitHub-reviewed advisory GHSA-h4ph-crvj-9h92 lists affected ranges: Packagist pimcore/admin-ui-classic-bundle >=2.0.0-RC1 =0 <1.7.18) Commands are suggestions: review each one before running it.
Loading voting…