Skip to content

← Actionable
High, CVSS 7.8amended

Systeminformation vulnerable to Linux command injection in networkInterfaces() via unsanitized NetworkManager connection profile name

CVE-2026-44724GHSA-hvx9-hwr7-wjj9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (systeminformation 5.31.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.8 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-44724: 0.92% estimated exploitation activity in the next 30 days; percentile 60.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary On Linux, systeminformation is vulnerable to command injection in networkInterfaces() when an active NetworkManager connection profile name contains shell metacharacters. This is not caused by a caller passing attacker-controlled arguments into networkInterfaces(). The vulnerable value is obtained internally from real nmcli device status output. The library sanitizes the network interface name before using it in shell commands, but it does not apply equivalent sanitization to the parsed NetworkManager connection profile name. That unsanitized connectionName is then interpolated into three shell command strings executed through execSync(). This issue was validated locally against real NetworkManager and real nmcli. Calling only: was enough to trigger execution. The injected command ran with the privileges of the calling Node.js process. Affected Component & Versions Affected component: - lib/network.js - networkInterfaces() - Linux NetworkManager / nmcli handling Impact &…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-hvx9-hwr7-wjj9

  2. Revision 1 · created ·

    Published from osv record GHSA-hvx9-hwr7-wjj9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44724

Advisory: Systeminformation vulnerable to Linux command injection in networkInterfaces() via unsanitized NetworkManager connection profile name
IDs: CVE-2026-44724, GHSA-hvx9-hwr7-wjj9
Record: https://patchnext.com/advisories/cve-2026-44724 (revision 2, source checked 26 Oct 2026, 12:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: systeminformation 5.31.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm systeminformation: affected >= 4.17.0, <= 5.31.5; fixed in 5.31.6

## Suggested inspection (read-only)
- `npm ls systeminformation --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on systeminformation.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hvx9-hwr7-wjj9 (OSV record GHSA-hvx9-hwr7-wjj9 lists affected ranges: npm systeminformation >=4.17.0 <5.31.6 (fixed))
- Verified: https://github.com/advisories/GHSA-hvx9-hwr7-wjj9 (GitHub-reviewed advisory GHSA-hvx9-hwr7-wjj9 lists affected ranges: npm systeminformation >=4.17.0 <=5.31.5)

Commands are suggestions: review each one before running it.

Loading voting…