Skip to content

← Actionable
High, CVSS 7.3amended

open-webui Vulnerable to Stored XSS via Model Description

CVE-2026-44721GHSA-gf5m-wcrh-7928

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (open-webui 0.9.0; open-webui 0.9.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-44721: 0.31% estimated exploitation activity in the next 30 days; percentile 23.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

[!IMPORTANT] Relationship to CVE-2024-7990 CVE-2024-7990 (issued by huntr.dev, March 2025) describes a stored XSS in the same field — the model description — but exploits a different bypass mechanism: a second-order injection through the sanitizeResponseContent function's video-tag placeholder restoration logic in v0.3.x. That bypass was closed in v0.4.0 by removing the video exemption from the sanitizer. The vulnerability described in this advisory is structurally distinct: a markdown-link payload with a javascript: URI passes through sanitizeResponseContent unchanged (no angle brackets), is then parsed by marked.parse() into an <a href="javascript:..." element, and rendered live by {@html}. This is a pipeline-ordering flaw where the dangerous construct is introduced after sanitization completes. Removing the video exemption has no effect on this primitive. Affected range: v0.3.5 through v0.8.12 inclusive. Fixed in: v0.9.0 (commit 5eab125, which wraps marked.parse() output in…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-gf5m-wcrh-7928

  2. Revision 1 · created ·

    Published from osv record GHSA-gf5m-wcrh-7928

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44721

Advisory: open-webui Vulnerable to Stored XSS via Model Description
IDs: CVE-2026-44721, GHSA-gf5m-wcrh-7928
Record: https://patchnext.com/advisories/cve-2026-44721 (revision 2, source checked 26 Oct 2026, 12:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: open-webui 0.9.0; open-webui 0.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm open-webui: affected <= 0.8.12; fixed in 0.9.0
- PyPI open-webui: affected <= 0.8.12; fixed in 0.9.0

## Suggested inspection (read-only)
- `npm ls open-webui --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `python -m pip show open-webui`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on open-webui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-gf5m-wcrh-7928 (OSV record GHSA-gf5m-wcrh-7928 lists affected ranges: npm open-webui >=0 =0 <0.9.0 (fixed))
- Verified: https://github.com/advisories/GHSA-gf5m-wcrh-7928 (GitHub-reviewed advisory GHSA-gf5m-wcrh-7928 lists affected ranges: npm open-webui >=0 =0 <=0.8.12)

Commands are suggestions: review each one before running it.

Loading voting…