Skip to content

← Actionable
High, CVSS 7.5amended

Pipecat: Path Traversal in Pipecat Runner /files Endpoint — Arbitrary File Read via %2F-Encoded Separator

CVE-2026-44716GHSA-3363-2ph6-35wh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pipecat-ai 1.2.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pipecat-ai

    Affected
    >= 0.0.90, < 1.2.0
    Fixed in
    1.2.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-44716: 0.42% estimated exploitation activity in the next 30 days; percentile 36.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A path traversal vulnerability exists in Pipecat's development runner (src/pipecat/runner/run.py). When the runner is started with the --folder flag, it exposes a GET /files/{filename:path} download endpoint. The filename path parameter is concatenated directly onto args.folder with no containment check. Starlette normalises literal ../ sequences in URLs, but %2F-encoded slashes bypass this normalisation: the path parameter is URL-decoded after routing, so ..%2F..%2Fetc%2Fpasswd resolves to a path two levels above args.folder. An attacker with network access to the runner can read any file the pipecat process has permission to access — including SSH private keys, credentials, and system files — with a single unauthenticated HTTP request. Confirmed on pipecat-ai 1.1.0 (latest PyPI release) and commit f078df78058ae82a02ce5b23e9e3a99a0917a53d. --- Details The vulnerable code is in src/pipecat/runner/run.py, inside the configureserverapp() function, lines 249–264:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-3363-2ph6-35wh

  2. Revision 1 · created ·

    Published from osv record GHSA-3363-2ph6-35wh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44716

Advisory: Pipecat: Path Traversal in Pipecat Runner `/files` Endpoint — Arbitrary File Read via `%2F`-Encoded Separator
IDs: CVE-2026-44716, GHSA-3363-2ph6-35wh
Record: https://patchnext.com/advisories/cve-2026-44716 (revision 2, source checked 26 Oct 2026, 13:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pipecat-ai 1.2.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pipecat-ai: affected >= 0.0.90, < 1.2.0; fixed in 1.2.0

## Suggested inspection (read-only)
- `python -m pip show pipecat-ai`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pipecat-ai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3363-2ph6-35wh (OSV record GHSA-3363-2ph6-35wh lists affected ranges: PyPI pipecat-ai >=0.0.90 <1.2.0 (fixed))
- Verified: https://github.com/advisories/GHSA-3363-2ph6-35wh (GitHub-reviewed advisory GHSA-3363-2ph6-35wh lists affected ranges: PyPI pipecat-ai >=0.0.90 <1.2.0)

Commands are suggestions: review each one before running it.

Loading voting…