Skip to content

← Actionable
High, CVSS 7.5

bitcoinj has a ScriptExecution P2PKH/P2WPKH Verification Bypass

CVE-2026-44714GHSA-hfcf-v2f8-x9pc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.bitcoinj:bitcoinj-core 0.17.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2026-44714: 0.27% estimated exploitation activity in the next 30 days; percentile 19.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary ScriptExecution.correctlySpends() contains two fast-path verification bugs for standard P2PKH and native P2WPKH spends in core/src/main/java/org/bitcoinj/script/ScriptExecution.java. In both branches, bitcoinj verifies an attacker-controlled signature/public-key pair but fails to verify that the public key is the one committed to by the output being spent. As a result, any attacker keypair can satisfy bitcoinj's local verification for arbitrary P2PKH and P2WPKH outputs. This doesn't affect the SPV (simple payment verification) trust model, as this model follows PoW and doesn't verify input signatures at all. Details The issue is in the optimized branches of ScriptExecution.correctlySpends(...). In the P2PKH fast path at core/src/main/java/org/bitcoinj/script/ScriptExecution.java:1042, the code: - parses the attacker-supplied signature from scriptSig - parses the attacker-supplied public key from scriptSig - computes the sighash against the victim output's scriptPubKey -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-hfcf-v2f8-x9pc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44714

Advisory: bitcoinj has a ScriptExecution P2PKH/P2WPKH Verification Bypass
IDs: CVE-2026-44714, GHSA-hfcf-v2f8-x9pc
Record: https://patchnext.com/advisories/cve-2026-44714 (revision 1, source checked 26 Oct 2026, 16:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.bitcoinj:bitcoinj-core 0.17.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.bitcoinj:bitcoinj-core: affected >= 0.15, < 0.17.1; fixed in 0.17.1

## Suggested inspection (read-only)
- Maven org.bitcoinj:bitcoinj-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.bitcoinj:bitcoinj-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hfcf-v2f8-x9pc (GitHub-reviewed advisory GHSA-hfcf-v2f8-x9pc lists affected ranges: Maven org.bitcoinj:bitcoinj-core >=0.15 <0.17.1)

Commands are suggestions: review each one before running it.

Loading voting…