Skip to content

← Actionable
High, CVSS 7.2amended

n8n-mcp webhook and API client paths has an authenticated SSRF

CVE-2026-44694GHSA-cmrh-wvq6-wm9r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n-mcp 2.50.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm n8n-mcp

    Affected
    >= 2.18.7, < 2.50.2
    Fixed in
    2.50.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.2 · CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:H/VI:L/VA:L/SC:H/SI:L/SA:L · score source
EPSS
  • CVE-2026-44694: 0.24% estimated exploitation activity in the next 30 days; percentile 14.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Authenticated Server-Side Request Forgery affecting the webhook trigger tools, the n8n API client (N8NAPIURL), and per-request URLs supplied via the x-n8n-url header in multi-tenant HTTP mode. Impact A caller with access to the MCP session can drive HTTP requests from the n8n-mcp host to internal services and cloud metadata endpoints that the SSRF gate is meant to block. The response body is returned to the caller, making internal-service enumeration and credential theft immediate without any out-of-band channel. - Multi-tenant HTTP deployments where tenants share an AUTHTOKEN: any tenant with valid credentials can reach the operator's cloud metadata service and exfiltrate temporary IAM / GCP service account / Azure managed-identity credentials. - Single-tenant deployments: indirect prompt injection through tool arguments reaches the same surface; an attacker who can influence the LLM's tool calls can read internal services from the n8n-mcp host. - Stdio deployments are…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-cmrh-wvq6-wm9r

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-cmrh-wvq6-wm9r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44694

Advisory: n8n-mcp webhook and API client paths has an authenticated SSRF
IDs: CVE-2026-44694, GHSA-cmrh-wvq6-wm9r
Record: https://patchnext.com/advisories/cve-2026-44694 (revision 3, source checked 26 Oct 2026, 12:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: n8n-mcp 2.50.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm n8n-mcp: affected >= 2.18.7, < 2.50.2; fixed in 2.50.2

## Suggested inspection (read-only)
- `npm ls n8n-mcp --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on n8n-mcp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-cmrh-wvq6-wm9r (OSV record GHSA-cmrh-wvq6-wm9r lists affected ranges: npm n8n-mcp >=2.18.7 <2.50.2 (fixed))
- Verified: https://github.com/advisories/GHSA-cmrh-wvq6-wm9r (GitHub-reviewed advisory GHSA-cmrh-wvq6-wm9r lists affected ranges: npm n8n-mcp >=2.18.7 <2.50.2)

Commands are suggestions: review each one before running it.

Loading voting…