Skip to content

← Actionable
High, CVSS 8.4amended

[Eclipse Theia] Arbitrary Command Execution via Untrusted Workspace Task Definitions

CVE-2026-44691GHSA-g9jw-92q7-g7fj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@theia/workspace 1.69.0; @theia/debug 1.69.0; @theia/task 1.69.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.4 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-44691: 0.41% estimated exploitation activity in the next 30 days; percentile 35.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In Eclipse Theia versions prior to 1.69.0, custom task definitions in workspace files (e.g. .theia/tasks.json, .vscode/tasks.json) could be executed without requiring workspace trust. An attacker could craft a malicious repository that, when cloned and opened in Theia, leads to execution of arbitrary commands with the user's privileges. In combination with AI chat features and a workspace .theia/settings.json that disabled tool confirmation, this could be triggered automatically by sending a message in the AI chat.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-g9jw-92q7-g7fj

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-g9jw-92q7-g7fj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44691

Advisory: [Eclipse Theia] Arbitrary Command Execution via Untrusted Workspace Task Definitions
IDs: CVE-2026-44691, GHSA-g9jw-92q7-g7fj
Record: https://patchnext.com/advisories/cve-2026-44691 (revision 3, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @theia/workspace 1.69.0; @theia/debug 1.69.0; @theia/task 1.69.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @theia/workspace: affected < 1.69.0; fixed in 1.69.0
- npm @theia/debug: affected < 1.69.0; fixed in 1.69.0
- npm @theia/task: affected < 1.69.0; fixed in 1.69.0

## Suggested inspection (read-only)
- `npm ls @theia/workspace --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @theia/debug --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @theia/task --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @theia/workspace, @theia/debug, @theia/task.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-g9jw-92q7-g7fj (OSV record GHSA-g9jw-92q7-g7fj lists affected ranges: npm @theia/debug >=0 =0 =0 <1.69.0 (fixed))
- Verified: https://github.com/advisories/GHSA-g9jw-92q7-g7fj (GitHub-reviewed advisory GHSA-g9jw-92q7-g7fj lists affected ranges: npm @theia/debug >=0 =0 =0 <1.69.0)

Commands are suggestions: review each one before running it.

Loading voting…