Authlib OIDC Implicit/Hybrid Authorization Vulnerable to Open Redirect
CVE-2026-44681GHSA-r95x-qfjj-fjj2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (authlib 1.7.1, 1.6.12), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI authlib
- Affected
- >= 1.7.0, <= 1.7.0<= 1.6.11
- Fixed in
- 1.7.1, 1.6.12
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-r95x-qfjj-fjj2 lists affected ranges: PyPI authlib >=1.7.0 =0 <1.6.12 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r95x-qfjj-fjj2 lists affected ranges: PyPI authlib >=1.7.0 =0 <=1.6.11
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2026-44681: 0.25% estimated exploitation activity in the next 30 days; percentile 16.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary An unauthenticated open redirect in Authlib's OpenIDImplicitGrant and OpenIDHybridGrant authorization endpoint lets a remote attacker cause the authorization server to issue an HTTP 302 to an attacker-chosen URL by submitting an authorization request that omits the openid scope. Details Vulnerable code OpenIDImplicitGrant.validateauthorizationrequest in authlib/oidc/core/grants/implicit.py: OpenIDHybridGrant.validateauthorizationrequest in authlib/oidc/core/grants/hybrid.py shares the same pattern. Root cause Both methods perform the openid scope presence check before delegating to super().validateauthorizationrequest(), which is where AuthorizationEndpointMixin.validateauthorizationredirecturi validates the requested redirecturi against the client's checkredirecturi(...). The InvalidScopeError thrown by the scope check therefore carries attacker-controlled self.request.payload.redirecturi. OAuth2Error.call in authlib/oauth2/base.py renders any error with a non-empty…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-r95x-qfjj-fjj2
- Revision 1 · created ·
Published from osv record GHSA-r95x-qfjj-fjj2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44681 Advisory: Authlib OIDC Implicit/Hybrid Authorization Vulnerable to Open Redirect IDs: CVE-2026-44681, GHSA-r95x-qfjj-fjj2 Record: https://patchnext.com/advisories/cve-2026-44681 (revision 2, source checked 26 Oct 2026, 13:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: authlib 1.7.1, 1.6.12. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI authlib: affected >= 1.7.0, <= 1.7.0; <= 1.6.11; fixed in 1.7.1, 1.6.12 ## Suggested inspection (read-only) - `python -m pip show authlib`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on authlib. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-r95x-qfjj-fjj2 (OSV record GHSA-r95x-qfjj-fjj2 lists affected ranges: PyPI authlib >=1.7.0 =0 <1.6.12 (fixed)) - Verified: https://github.com/advisories/GHSA-r95x-qfjj-fjj2 (GitHub-reviewed advisory GHSA-r95x-qfjj-fjj2 lists affected ranges: PyPI authlib >=1.7.0 =0 <=1.6.11) Commands are suggestions: review each one before running it.
Loading voting…