Skip to content

← Actionable
Critical, CVSS 9.3

Mapfish Print: Remote Code Injection (RCE) in Dynamic table

CVE-2026-44672GHSA-q7m6-wpvf-mvwx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.mapfish.print:print-lib 4.0.3, 3.33.14, 3.31.21, 3.30.30, 3.28.28; org.mapfish.print:print-servlet 4.0.3, 3.33.14, 3.31.21, 3.30.30, 3.28.28), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven org.mapfish.print:print-lib

    Affected
    >= 3.23.0, < 3.28.28>= 3.29.0, < 3.30.30>= 3.31.0, < 3.31.21>= 3.32.0, < 3.33.14>= 3.34.0, < 4.0.3
    Fixed in
    3.33.14, 3.28.28, 3.30.30, 4.0.3, 3.31.21
  • Maven org.mapfish.print:print-servlet

    Affected
    >= 3.23.0, < 3.28.28>= 3.29.0, < 3.30.30>= 3.31.0, < 3.31.21>= 3.32.0, < 3.33.14>= 3.34.0, < 4.0.3
    Fixed in
    3.33.14, 3.28.28, 3.30.30, 4.0.3, 3.31.21

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-q7m6-wpvf-mvwx lists affected ranges: Maven org.mapfish.print:print-lib >=3.23.0 =3.29.0 =3.31.0 =3.32.0 =3.34.0 =3.23.0 =3.29.0 =3.31.0 =3.32.0 =3.34.0 <4.0.3

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-44672: 0.33% estimated exploitation activity in the next 30 days; percentile 25.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The attacker can execute arbitrary code without being authenticated Mitigation Upgrade to a patched version (please check affected/patched version matrix) Credits Bug Bounty of Canton du Jura

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-q7m6-wpvf-mvwx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44672

Advisory: Mapfish Print: Remote Code Injection (RCE) in Dynamic table
IDs: CVE-2026-44672, GHSA-q7m6-wpvf-mvwx
Record: https://patchnext.com/advisories/cve-2026-44672 (revision 1, source checked 26 Oct 2026, 16:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.mapfish.print:print-lib 4.0.3, 3.33.14, 3.31.21, 3.30.30, 3.28.28; org.mapfish.print:print-servlet 4.0.3, 3.33.14, 3.31.21, 3.30.30, 3.28.28. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.mapfish.print:print-lib: affected >= 3.23.0, < 3.28.28; >= 3.29.0, < 3.30.30; >= 3.31.0, < 3.31.21; >= 3.32.0, < 3.33.14; >= 3.34.0, < 4.0.3; fixed in 3.33.14, 3.28.28, 3.30.30, 4.0.3, 3.31.21
- Maven org.mapfish.print:print-servlet: affected >= 3.23.0, < 3.28.28; >= 3.29.0, < 3.30.30; >= 3.31.0, < 3.31.21; >= 3.32.0, < 3.33.14; >= 3.34.0, < 4.0.3; fixed in 3.33.14, 3.28.28, 3.30.30, 4.0.3, 3.31.21

## Suggested inspection (read-only)
- Maven org.mapfish.print:print-lib: check the installed version with your package manager.
- Maven org.mapfish.print:print-servlet: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.mapfish.print:print-lib, org.mapfish.print:print-servlet.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-q7m6-wpvf-mvwx (GitHub-reviewed advisory GHSA-q7m6-wpvf-mvwx lists affected ranges: Maven org.mapfish.print:print-lib >=3.23.0 =3.29.0 =3.31.0 =3.32.0 =3.34.0 =3.23.0 =3.29.0 =3.31.0 =3.32.0 =3.34.0 <4.0.3)

Commands are suggestions: review each one before running it.

Loading voting…