SillyTavern has a reflected XSS vulnerability in the CORS proxy middleware
CVE-2026-44651GHSA-xc4x-2452-5gc9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sillytavern 1.18.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm sillytavern
- Affected
- <= 1.17.0
- Fixed in
- 1.18.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xc4x-2452-5gc9 lists affected ranges: npm sillytavern >=0 <1.18.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xc4x-2452-5gc9 lists affected ranges: npm sillytavern >=0 <=1.17.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-44651: 0.32% estimated exploitation activity in the next 30 days; percentile 25.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Resolution Fixed in SillyTavern 1.18.0: a user-provided URL is no longer reflected in the HTTP response body. Overview - Vulnerability Type: XSS - Affected Location: src/middleware/corsProxy.js:40 - Trigger Scenario: reflected XSS in CORS proxy error response Root Cause When fetch(url) throws, the code sends: res.status(500).send('Error occurred while trying to proxy to: ' + url + ' ' + error). The url value is attacker-controlled (req.params.url) and is not HTML-escaped before rendering. Source-to-Sink Chain 1. Source (user-controlled input) - Entry point: GET /proxy/:url() 2. Data flow - Code analysis shows concrete propagation into this sink: - vulnerability title: Reflected XSS in CORS proxy error response - sink location reached by attacker-controlled input: src/middleware/corsProxy.js:40 - The same sink behavior is confirmed by controlled execution observations. 3. Sink (dangerous operation) - Sink location: src/middleware/corsProxy.js:40 - Vulnerable behavior: reflected XSS in…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-xc4x-2452-5gc9
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-xc4x-2452-5gc9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44651 Advisory: SillyTavern has a reflected XSS vulnerability in the CORS proxy middleware IDs: CVE-2026-44651, GHSA-xc4x-2452-5gc9 Record: https://patchnext.com/advisories/cve-2026-44651 (revision 3, source checked 26 Oct 2026, 12:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sillytavern 1.18.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm sillytavern: affected <= 1.17.0; fixed in 1.18.0 ## Suggested inspection (read-only) - `npm ls sillytavern --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sillytavern. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-xc4x-2452-5gc9 (OSV record GHSA-xc4x-2452-5gc9 lists affected ranges: npm sillytavern >=0 <1.18.0 (fixed)) - Verified: https://github.com/advisories/GHSA-xc4x-2452-5gc9 (GitHub-reviewed advisory GHSA-xc4x-2452-5gc9 lists affected ranges: npm sillytavern >=0 <=1.17.0) Commands are suggestions: review each one before running it.
Loading voting…