SillyTavern has Authentication Bypass via SSO Header Injection
CVE-2026-44649GHSA-gxx6-h3g6-vwjh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sillytavern 1.18.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm sillytavern
- Affected
- <= 1.17.0
- Fixed in
- 1.18.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gxx6-h3g6-vwjh lists affected ranges: npm sillytavern >=0 <=1.17.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-gxx6-h3g6-vwjh lists affected ranges: npm sillytavern >=0 <1.18.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-44649: 0.22% estimated exploitation activity in the next 30 days; percentile 12.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Resolution SillyTavern 1.18.0 now includes a configuration option to limit which IP addresses can authorize using SSO headers, limiting to just loopback addresses by default. A setting can be customized according to user's needs. Documentation: https://docs.sillytavern.app/administration/sso/ Summary SillyTavern accepts Remote-User (Authelia) and X-Authentik-Username (Authentik) HTTP headers to automatically log in users when SSO is configured. There is no validation that these headers originate from a trusted reverse proxy. Any network client that can reach the SillyTavern port directly can inject these headers and authenticate as any user, including administrators, without a password. This vulnerability is exploitable only when sso.autheliaAuth: true or sso.authentikAuth: true is set in config.yaml (both default to false). Detials SillyTavern implements header-based SSO for Authelia and Authentik. When enabled, the tryAutoLogin function (called on every request to /login) invokes…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-gxx6-h3g6-vwjh
- Revision 2 · amended ·
Amended from osv record GHSA-gxx6-h3g6-vwjh
- Revision 1 · created ·
Published from ghsa record GHSA-gxx6-h3g6-vwjh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44649 Advisory: SillyTavern has Authentication Bypass via SSO Header Injection IDs: CVE-2026-44649, GHSA-gxx6-h3g6-vwjh Record: https://patchnext.com/advisories/cve-2026-44649 (revision 3, source checked 26 Oct 2026, 12:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sillytavern 1.18.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm sillytavern: affected <= 1.17.0; fixed in 1.18.0 ## Suggested inspection (read-only) - `npm ls sillytavern --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sillytavern. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-gxx6-h3g6-vwjh (GitHub-reviewed advisory GHSA-gxx6-h3g6-vwjh lists affected ranges: npm sillytavern >=0 <=1.17.0) - Verified: https://osv.dev/vulnerability/GHSA-gxx6-h3g6-vwjh (OSV record GHSA-gxx6-h3g6-vwjh lists affected ranges: npm sillytavern >=0 <1.18.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…