Angular Expressions - Remote Code Execution using filters
CVE-2026-44643GHSA-pw8r-6689-xvf4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (angular-expressions 1.5.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- <= 1.5.1
- Fixed in
- 1.5.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pw8r-6689-xvf4 lists affected ranges: npm angular-expressions >=0 <=1.5.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pw8r-6689-xvf4 lists affected ranges: npm angular-expressions >=0 <1.5.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-44643: 0.48% estimated exploitation activity in the next 30 days; percentile 41.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An attacker can write a malicious expression that escapes the sandbox to execute arbitrary code on the system. Example of vulnerable code: This should throw the error : Filter 'proto' is not defined, however, this shows : Uncaught SyntaxError: Unexpected identifier 'Object' With a more complex (undisclosed) payload, one can get full access to Arbitrary code execution on the system. Vulnerable versions : angular-expressions <= 1.5.1 Patches The problem has been patched in version 1.5.2 of angular-expressions. Credits Credits go to San Gil from www.securityoffice.io who has found the issue and reported it to us.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-pw8r-6689-xvf4
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-pw8r-6689-xvf4
- Revision 1 · created ·
Published from ghsa record GHSA-pw8r-6689-xvf4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44643 Advisory: Angular Expressions - Remote Code Execution using filters IDs: CVE-2026-44643, GHSA-pw8r-6689-xvf4 Record: https://patchnext.com/advisories/cve-2026-44643 (revision 4, source checked 26 Oct 2026, 12:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: angular-expressions 1.5.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm angular-expressions: affected <= 1.5.1; fixed in 1.5.2 ## Suggested inspection (read-only) - `npm ls angular-expressions --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on angular-expressions. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-pw8r-6689-xvf4 (GitHub-reviewed advisory GHSA-pw8r-6689-xvf4 lists affected ranges: npm angular-expressions >=0 <=1.5.1) - Verified: https://osv.dev/vulnerability/GHSA-pw8r-6689-xvf4 (OSV record GHSA-pw8r-6689-xvf4 lists affected ranges: npm angular-expressions >=0 <1.5.2 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…