Skip to content

← Actionable
High, CVSS 7.1amended

Microsoft APM CLI's plugin.json component paths escape plugin root and copy arbitrary host files during install

CVE-2026-44641GHSA-xhrw-5qxx-jpwr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (apm-cli 0.8.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI apm-cli

    Affected
    <= 0.8.11
    Fixed in
    0.8.12

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-44641: 0.43% estimated exploitation activity in the next 30 days; percentile 37.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Microsoft APM normalizes marketplace plugins by copying plugin components referenced in plugin.json into .apm/. The manifest fields agents, skills, commands, and hooks are attacker-controlled, but the implementation does not enforce that those paths remain inside the plugin directory. A malicious plugin can therefore use absolute paths or ../ traversal paths to copy arbitrary readable host files or directories from the installer's machine during apm install. In the verified primary proof of concept, a malicious plugin sets plugin.json.commands to an external markdown file. A single apm install copies that outside file into .apm/prompts/ and then auto-integrates it into .github/prompts/secret.prompt.md in the victim project. This is a local supply-chain trust-boundary violation with direct confidentiality and integrity impact. Reviewed version and commit: - apm-cli version 0.8.11 - main commit 70b34faa16a5a783424698163deeb028854fd23a Details Root cause: -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-xhrw-5qxx-jpwr

  2. Revision 1 · created ·

    Published from osv record GHSA-xhrw-5qxx-jpwr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44641

Advisory: Microsoft APM CLI's plugin.json component paths escape plugin root and copy arbitrary host files during install
IDs: CVE-2026-44641, GHSA-xhrw-5qxx-jpwr
Record: https://patchnext.com/advisories/cve-2026-44641 (revision 2, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: apm-cli 0.8.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI apm-cli: affected <= 0.8.11; fixed in 0.8.12

## Suggested inspection (read-only)
- `python -m pip show apm-cli`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on apm-cli.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-xhrw-5qxx-jpwr (OSV record GHSA-xhrw-5qxx-jpwr lists affected ranges: PyPI apm-cli >=0 <0.8.12 (fixed))
- Verified: https://github.com/advisories/GHSA-xhrw-5qxx-jpwr (GitHub-reviewed advisory GHSA-xhrw-5qxx-jpwr lists affected ranges: PyPI apm-cli >=0 <=0.8.11)

Commands are suggestions: review each one before running it.

Loading voting…