Yamcs has No Rate Limiting on Authentication Endpoint
CVE-2026-44596GHSA-w5r6-mcgq-7pq4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.yamcs:yamcs-core 5.12.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.yamcs:yamcs-core
- Affected
- < 5.12.7
- Fixed in
- 5.12.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w5r6-mcgq-7pq4 lists affected ranges: Maven org.yamcs:yamcs-core >=0 <5.12.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- EPSS
- CVE-2026-44596: 2.06% estimated exploitation activity in the next 30 days; percentile 81.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The authentication endpoint POST /auth/token in yamcs-core lacks any form of rate limiting, account lockout, or failed attempt throttling. As a result, an unauthenticated remote attacker can perform unlimited password guessing attempts against any user account. This missing rate limiting vulnerability (CWE-307) significantly increases the risk of successful brute-force attacks. Root Cause File: yamcs-core/src/main/java/org/yamcs/http/auth/AuthHandler.java POST /auth/token has no rate limiting, no lockout after failed attempts, and no CAPTCHA. The handler processes unlimited authentication requests without any throttling mechanism: This is absent by default — the official quickstart and documentation contain no guidance on configuring rate limiting. Impact An attacker can make unlimited authentication attempts against any account. This enables efficient brute-force attacks against any account. Proof of Concept Confirmed: 20 attempts in 0.07 seconds, no rate limiting enforced.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-w5r6-mcgq-7pq4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44596 Advisory: Yamcs has No Rate Limiting on Authentication Endpoint IDs: CVE-2026-44596, GHSA-w5r6-mcgq-7pq4 Record: https://patchnext.com/advisories/cve-2026-44596 (revision 1, source checked 26 Oct 2026, 16:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.yamcs:yamcs-core 5.12.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.yamcs:yamcs-core: affected < 5.12.7; fixed in 5.12.7 ## Suggested inspection (read-only) - Maven org.yamcs:yamcs-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.yamcs:yamcs-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-w5r6-mcgq-7pq4 (GitHub-reviewed advisory GHSA-w5r6-mcgq-7pq4 lists affected ranges: Maven org.yamcs:yamcs-core >=0 <5.12.7) Commands are suggestions: review each one before running it.
Loading voting…