Yamcs vulnerable to unauthorized user enumeration via IAM API endpoints
CVE-2026-44595GHSA-p2rj-mrmc-9w29
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.yamcs:yamcs-core 5.12.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.yamcs:yamcs-core
- Affected
- < 5.12.7
- Fixed in
- 5.12.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p2rj-mrmc-9w29 lists affected ranges: Maven org.yamcs:yamcs-core >=0 <5.12.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2026-44595: 1.06% estimated exploitation activity in the next 30 days; percentile 64.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The IAM API endpoints (listUsers, getUser, listGroups, and getGroup) in yamcs-core do not enforce the required SystemPrivilege.ControlAccess check. As a result, any authenticated user (even those with low or no privileges) can enumerate all user accounts in the system, including their usernames, superuser status, and group memberships. This constitutes a broken access control vulnerability (CWE-862) that leaks sensitive user information. Root Cause File: yamcs-core/src/main/java/org/yamcs/http/api/IamApi.java:125,180,357,372 listUsers(), getUser(), listGroups(), and getGroup() do not require SystemPrivilege.ControlAccess. Any authenticated user — regardless of privileges — can enumerate all users, their superuser status, and group memberships: Compare with properly protected endpoints: Impact Any authenticated user can: 1. List all user accounts in the system 2. Identify which accounts have superuser privileges 3. Use this information to target privileged accounts Proof of…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-p2rj-mrmc-9w29
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44595 Advisory: Yamcs vulnerable to unauthorized user enumeration via IAM API endpoints IDs: CVE-2026-44595, GHSA-p2rj-mrmc-9w29 Record: https://patchnext.com/advisories/cve-2026-44595 (revision 1, source checked 26 Oct 2026, 16:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.yamcs:yamcs-core 5.12.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.yamcs:yamcs-core: affected < 5.12.7; fixed in 5.12.7 ## Suggested inspection (read-only) - Maven org.yamcs:yamcs-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.yamcs:yamcs-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-p2rj-mrmc-9w29 (GitHub-reviewed advisory GHSA-p2rj-mrmc-9w29 lists affected ranges: Maven org.yamcs:yamcs-core >=0 <5.12.7) Commands are suggestions: review each one before running it.
Loading voting…