Skip to content

← Actionable
Medium, CVSS 4.7

CarrierWave has a denylisted_content_type bypass via Unescaped Regex Metacharacters

CVE-2026-44587GHSA-7g26-2qgj-chfg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (carrierwave 3.1.3, 2.2.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems carrierwave

    Affected
    >= 3.0.0.beta, < 3.1.3< 2.2.7
    Fixed in
    2.2.7, 3.1.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.7 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:N/A:N
EPSS
  • CVE-2026-44587: 0.22% estimated exploitation activity in the next 30 days; percentile 13.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary CarrierWave's contenttypedenylist check fails to escape regex metacharacters in string entries, causing the denylist to silently not match the content types it is intended to block. Note: CarrierWave is aware #contenttypedenylist is deprecated for the security reason, but it still used by developers, and the problem here isn't denylist allows any filetype, and thats not a vulnerability in carrierwave, its an implementation problem in developers using CarrierWave, the problem is its denylist entries are interpolated directly into a regex without Regexp.quote or anchoring. The denylist is still useful when developers want to ban specific content types but allow everything else. Details In lib/carrierwave/uploader/contenttypedenylist.rb:57, string denylist entries are interpolated directly into a regex without Regexp.quote or anchoring: Other affected MIME types include application/xhtml+xml and any type containing regex metacharacters. Fix: Apply Regexp.quote for string entries…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-7g26-2qgj-chfg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44587

Advisory: CarrierWave has a denylisted_content_type bypass via Unescaped Regex Metacharacters
IDs: CVE-2026-44587, GHSA-7g26-2qgj-chfg
Record: https://patchnext.com/advisories/cve-2026-44587 (revision 1, source checked 26 Oct 2026, 15:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: carrierwave 3.1.3, 2.2.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems carrierwave: affected >= 3.0.0.beta, < 3.1.3; < 2.2.7; fixed in 2.2.7, 3.1.3

## Suggested inspection (read-only)
- RubyGems carrierwave: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on carrierwave.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7g26-2qgj-chfg (GitHub-reviewed advisory GHSA-7g26-2qgj-chfg lists affected ranges: RubyGems carrierwave >=3.0.0.beta =0 <2.2.7)

Commands are suggestions: review each one before running it.

Loading voting…