Paymenter has broken object level authorization via service reference manipulation on ticket creation
CVE-2026-44585GHSA-x93q-x9pc-w5hw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (paymenter/paymenter 1.5.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist paymenter/paymenter
- Affected
- < 1.5.0
- Fixed in
- 1.5.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x93q-x9pc-w5hw lists affected ranges: Packagist paymenter/paymenter >=0 <1.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- EPSS
- CVE-2026-44585: 0.29% estimated exploitation activity in the next 30 days; percentile 21.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The ticket creation endpoint accepts a user-supplied service identifier without enforcing ownership validation, allowing authenticated users to create support tickets referencing services belonging to other accounts by modifying the service ID in the request. Technical Details The ticket creation endpoint accepted a user-supplied service identifier without verifying ownership or authorization against the authenticated account. An attacker could modify the service ID value in the client-side request and successfully create a ticket associated with another user's service. The vulnerability required authentication and did not provide direct access to service contents or customer data. However, referenced service information could become visible to support personnel handling the ticket. Impact Successful exploitation could allow an authenticated user to: - Create support tickets referencing services belonging to other users - Potentially cause support staff to interact with or…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-x93q-x9pc-w5hw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44585 Advisory: Paymenter has broken object level authorization via service reference manipulation on ticket creation IDs: CVE-2026-44585, GHSA-x93q-x9pc-w5hw Record: https://patchnext.com/advisories/cve-2026-44585 (revision 1, source checked 26 Oct 2026, 14:49 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: paymenter/paymenter 1.5.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist paymenter/paymenter: affected < 1.5.0; fixed in 1.5.0 ## Suggested inspection (read-only) - Packagist paymenter/paymenter: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on paymenter/paymenter. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-x93q-x9pc-w5hw (GitHub-reviewed advisory GHSA-x93q-x9pc-w5hw lists affected ranges: Packagist paymenter/paymenter >=0 <1.5.0) Commands are suggestions: review each one before running it.
Loading voting…