Skip to content

← Actionable
Medium, CVSS 4.3

Paymenter doesn't reset email verification status after email change

CVE-2026-44584GHSA-rv89-wch8-c574

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (paymenter/paymenter 1.5.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2026-44584: 0.16% estimated exploitation activity in the next 30 days; percentile 5.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The email update functionality fails to invalidate the existing verification state when a user changes their email address, allowing a verified account to retain its verified status after switching to an unverified or unowned email address. Technical Details When a user updated their email address, the system did not reset or revalidate the associated email verification status. As a result, the verification column remained set to “true” even after the email address was changed. This allowed an attacker to: - Verify an account using a legitimate email address - Change the account email to an arbitrary or unowned address - Retain the verified status without re-confirmation of the new email No verification challenge or confirmation was required for the newly assigned email address. Impact This vulnerability allows a user to associate a verified account with an email address they do not control, this may result in: - Misrepresentation of email ownership - Bypass of…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-rv89-wch8-c574

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44584

Advisory: Paymenter doesn't reset email verification status after email change
IDs: CVE-2026-44584, GHSA-rv89-wch8-c574
Record: https://patchnext.com/advisories/cve-2026-44584 (revision 1, source checked 26 Oct 2026, 14:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: paymenter/paymenter 1.5.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist paymenter/paymenter: affected < 1.5.0; fixed in 1.5.0

## Suggested inspection (read-only)
- Packagist paymenter/paymenter: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on paymenter/paymenter.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-rv89-wch8-c574 (GitHub-reviewed advisory GHSA-rv89-wch8-c574 lists affected ranges: Packagist paymenter/paymenter >=0 <1.5.0)

Commands are suggestions: review each one before running it.

Loading voting…