Paymenter has Blind Unauthenticated SSRF on the Paypal gateway module
CVE-2026-44583GHSA-7wwh-xcc3-9fcg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (paymenter/paymenter 1.5.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist paymenter/paymenter
- Affected
- < 1.5.0
- Fixed in
- 1.5.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7wwh-xcc3-9fcg lists affected ranges: Packagist paymenter/paymenter >=0 <1.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2026-44583: 0.41% estimated exploitation activity in the next 30 days; percentile 35.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The PayPal webhook endpoint /extensions/paypal/webhook processes the PAYPAL-CERT-URL HTTP header without validation, allowing attackers to control server-side HTTP request destinations. Technical details: The /extensions/paypal/webhook endpoint processes incoming webhook requests and trusts the value of the PAYPAL-CERT-URL HTTP header without validation. This value is passed directly into a server-side HTTP request via filegetcontents, allowing attackers to control the destination of the request. No allowlist, validation, or signature verification is applied to the header before usage. As a result, the application can be coerced into performing HTTP requests to attacker-controlled or internal network destinations. Impact This vulnerability allows remote unauthenticated attackers to induce server-side HTTP GET requests to arbitrary external or internal endpoints. Depending on network configuration, this may lead to: - Blind SSRF to external attacker-controlled systems -…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-7wwh-xcc3-9fcg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44583 Advisory: Paymenter has Blind Unauthenticated SSRF on the Paypal gateway module IDs: CVE-2026-44583, GHSA-7wwh-xcc3-9fcg Record: https://patchnext.com/advisories/cve-2026-44583 (revision 1, source checked 26 Oct 2026, 14:49 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: paymenter/paymenter 1.5.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist paymenter/paymenter: affected < 1.5.0; fixed in 1.5.0 ## Suggested inspection (read-only) - Packagist paymenter/paymenter: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on paymenter/paymenter. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7wwh-xcc3-9fcg (GitHub-reviewed advisory GHSA-7wwh-xcc3-9fcg lists affected ranges: Packagist paymenter/paymenter >=0 <1.5.0) Commands are suggestions: review each one before running it.
Loading voting…