Next.js vulnerable to cache poisoning via collisions in React Server Component cache-busting
CVE-2026-44582GHSA-vfv6-92ff-j949
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (next 16.2.5, 15.5.16), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm next
- Affected
- >= 13.4.6, < 15.5.16>= 16.0.0, < 16.2.5
- Fixed in
- 16.2.5, 15.5.16
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vfv6-92ff-j949 lists affected ranges: npm next >=13.4.6 =16.0.0 <16.2.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vfv6-92ff-j949 lists affected ranges: npm next >=13.4.6 =16.0.0 <16.2.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2026-44582: 0.21% estimated exploitation activity in the next 30 days; percentile 11.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact React Server Component responses can be vulnerable to cache poisoning in deployments that rely on shared caches with insufficient response partitioning. In affected conditions, collisions in the rsc cache-busting value can allow an attacker to poison cache entries so users receive the wrong response variant for a given URL. Fix We strengthened the rsc cache-busting mechanism to make practical collisions significantly harder and to better separate response variants that should not share cache entries. Workarounds If you cannot upgrade immediately, ensure intermediary caches correctly honor Vary for RSC-related request headers, or disable shared caching for affected RSC responses until you can deploy a patched release.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-vfv6-92ff-j949
- Revision 1 · created ·
Published from osv record GHSA-vfv6-92ff-j949
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44582 Advisory: Next.js vulnerable to cache poisoning via collisions in React Server Component cache-busting IDs: CVE-2026-44582, GHSA-vfv6-92ff-j949 Record: https://patchnext.com/advisories/cve-2026-44582 (revision 2, source checked 26 Oct 2026, 12:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: next 16.2.5, 15.5.16. A vendor fix does not mean a deployment is fixed. ## Affected components - npm next: affected >= 13.4.6, < 15.5.16; >= 16.0.0, < 16.2.5; fixed in 16.2.5, 15.5.16 ## Suggested inspection (read-only) - `npm ls next --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on next. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-vfv6-92ff-j949 (OSV record GHSA-vfv6-92ff-j949 lists affected ranges: npm next >=13.4.6 =16.0.0 <16.2.5 (fixed)) - Verified: https://github.com/advisories/GHSA-vfv6-92ff-j949 (GitHub-reviewed advisory GHSA-vfv6-92ff-j949 lists affected ranges: npm next >=13.4.6 =16.0.0 <16.2.5) Commands are suggestions: review each one before running it.
Loading voting…