Skip to content

← Actionable
High, CVSS 7.5amended

Next.js vulnerable to Denial of Service via connection exhaustion in applications using Cache Components

CVE-2026-44579GHSA-mg66-mrh9-m8jx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (next 16.2.5, 15.5.16), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm next

    Affected
    >= 15.0.0, < 15.5.16>= 16.0.0, < 16.2.5
    Fixed in
    16.2.5, 15.5.16

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-44579: 0.75% estimated exploitation activity in the next 30 days; percentile 54.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Applications using Partial Prerendering through the Cache Components feature can be vulnerable to connection exhaustion through crafted POST requests to a server action. In affected configurations, a malicious request can trigger a request-body handling deadlock that leaves connections open for an extended period, consuming file descriptors and server capacity until legitimate users are denied service. Fix We now treat the header used for resuming Partial Prerendered requests as an internal-only header and strip it from untrusted incoming requests. This header should never be accepted directly from external clients. Workarounds If you cannot upgrade immediately, block requests that would be handled by Next.js if they contain the Next-Resume header at the edge.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-mg66-mrh9-m8jx

  2. Revision 1 · created ·

    Published from osv record GHSA-mg66-mrh9-m8jx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44579

Advisory: Next.js vulnerable to Denial of Service via connection exhaustion in applications using Cache Components
IDs: CVE-2026-44579, GHSA-mg66-mrh9-m8jx
Record: https://patchnext.com/advisories/cve-2026-44579 (revision 2, source checked 26 Oct 2026, 12:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: next 16.2.5, 15.5.16. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm next: affected >= 15.0.0, < 15.5.16; >= 16.0.0, < 16.2.5; fixed in 16.2.5, 15.5.16

## Suggested inspection (read-only)
- `npm ls next --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on next.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mg66-mrh9-m8jx (OSV record GHSA-mg66-mrh9-m8jx lists affected ranges: npm next >=15.0.0 =16.0.0 <16.2.5 (fixed))
- Verified: https://github.com/advisories/GHSA-mg66-mrh9-m8jx (GitHub-reviewed advisory GHSA-mg66-mrh9-m8jx lists affected ranges: npm next >=15.0.0 =16.0.0 <16.2.5)

Commands are suggestions: review each one before running it.

Loading voting…