Skip to content

← Actionable
Medium, CVSS 5.9amended

Next.js has a Denial of Service in the Image Optimization API

CVE-2026-44577GHSA-h64f-5h5j-jqjh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (next 16.2.5, 15.5.16), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm next

    Affected
    >= 10.0.0, < 15.5.16>= 16.0.0, < 16.2.5
    Fixed in
    16.2.5, 15.5.16

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-44577: 0.74% estimated exploitation activity in the next 30 days; percentile 54.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact When self-hosting Next.js with the default image loader, the Image Optimization API fetches local images entirely into memory without enforcing a maximum size limit. An attacker could cause out-of-memory conditions by requesting large local assets from the /next/image endpoint that match the images.localPatterns configuration (by default, all patterns are allowed). - If you are using images.localPatterns, only the patterns in that array are impacted. - If you are using images.unoptimized: true, you are NOT impacted. - If you are using images.loader: 'custom', you are NOT impacted. - If you are using Vercel, you are NOT impacted. Fix We now apply response size limits consistently to internal image fetches, not just external ones, and fail oversized responses before they can exhaust process memory. This can be adjusted using the images.maximumResponseBody configuration. Workarounds If you cannot upgrade immediately, avoid routing large local assets through /next/image, disable…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-h64f-5h5j-jqjh

  2. Revision 1 · created ·

    Published from osv record GHSA-h64f-5h5j-jqjh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44577

Advisory: Next.js has a Denial of Service in the Image Optimization API
IDs: CVE-2026-44577, GHSA-h64f-5h5j-jqjh
Record: https://patchnext.com/advisories/cve-2026-44577 (revision 2, source checked 26 Oct 2026, 12:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: next 16.2.5, 15.5.16. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm next: affected >= 10.0.0, < 15.5.16; >= 16.0.0, < 16.2.5; fixed in 16.2.5, 15.5.16

## Suggested inspection (read-only)
- `npm ls next --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on next.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-h64f-5h5j-jqjh (OSV record GHSA-h64f-5h5j-jqjh lists affected ranges: npm next >=10.0.0 =16.0.0 <16.2.5 (fixed))
- Verified: https://github.com/advisories/GHSA-h64f-5h5j-jqjh (GitHub-reviewed advisory GHSA-h64f-5h5j-jqjh lists affected ranges: npm next >=10.0.0 =16.0.0 <16.2.5)

Commands are suggestions: review each one before running it.

Loading voting…