Skip to content

← Actionable
Medium, CVSS 5.4amended

Next.js vulnerable to cache poisoning in React Server Component responses

CVE-2026-44576GHSA-wfc6-r584-vfw7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (next 16.2.5, 15.5.16), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm next

    Affected
    >= 14.2.0, < 15.5.16>= 16.0.0, < 16.2.5
    Fixed in
    16.2.5, 15.5.16

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:N/I:L/A:L
EPSS
  • CVE-2026-44576: 0.29% estimated exploitation activity in the next 30 days; percentile 22.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Applications using React Server Components can be vulnerable to cache poisoning when shared caches do not correctly partition response variants. Under affected conditions, an attacker can cause an RSC response to be served from the original URL and poison shared cache entries so later visitors receive component payloads instead of the expected HTML. Fix We now validate and interpret RSC request headers consistently across request classification and rendering, and we enforce the intended cache-busting behavior so RSC payloads are not unexpectedly served from the original URL. Workarounds If you cannot upgrade immediately, ensure your CDN or reverse proxy keys on the relevant RSC request headers and honors Vary, or disable shared caching for affected App Router and RSC responses.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-wfc6-r584-vfw7

  2. Revision 1 · created ·

    Published from osv record GHSA-wfc6-r584-vfw7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44576

Advisory: Next.js vulnerable to cache poisoning in React Server Component responses
IDs: CVE-2026-44576, GHSA-wfc6-r584-vfw7
Record: https://patchnext.com/advisories/cve-2026-44576 (revision 2, source checked 26 Oct 2026, 12:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: next 16.2.5, 15.5.16. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm next: affected >= 14.2.0, < 15.5.16; >= 16.0.0, < 16.2.5; fixed in 16.2.5, 15.5.16

## Suggested inspection (read-only)
- `npm ls next --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on next.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-wfc6-r584-vfw7 (OSV record GHSA-wfc6-r584-vfw7 lists affected ranges: npm next >=14.2.0 =16.0.0 <16.2.5 (fixed))
- Verified: https://github.com/advisories/GHSA-wfc6-r584-vfw7 (GitHub-reviewed advisory GHSA-wfc6-r584-vfw7 lists affected ranges: npm next >=14.2.0 =16.0.0 <16.2.5)

Commands are suggestions: review each one before running it.

Loading voting…