Skip to content

← Actionable
Low, CVSS 3.7amended

Next.js's Middleware / Proxy redirects can be cache-poisoned

CVE-2026-44572GHSA-3g8h-86w9-wvmq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (next 16.2.5, 15.5.16), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm next

    Affected
    >= 12.2.0, < 15.5.16>= 16.0.0, < 16.2.5
    Fixed in
    16.2.5, 15.5.16

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2026-44572: 0.28% estimated exploitation activity in the next 30 days; percentile 20.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Next.js uses the x-nextjs-data request header for internal data requests. On affected versions, an external client could send this header on a normal request to a path handled by middleware that returns a redirect. When that happened, the middleware/proxy could treat the request as a data request and replace the standard Location redirect header with the internal x-nextjs-redirect header. Browsers do not follow x-nextjs-redirect, so the response became an unusable redirect for normal clients. If the application was deployed behind a CDN or reverse proxy that caches 3xx responses without varying on this header, a single attacker request could poison the cached redirect response for the affected path. Subsequent visitors could then receive a cached redirect response without a Location header, causing a denial of service for that redirect path until the cache entry expired or was purged. Affected scenarios This affects applications that: - use middleware or proxy redirects - are…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-3g8h-86w9-wvmq

  2. Revision 1 · created ·

    Published from osv record GHSA-3g8h-86w9-wvmq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44572

Advisory: Next.js's Middleware / Proxy redirects can be cache-poisoned
IDs: CVE-2026-44572, GHSA-3g8h-86w9-wvmq
Record: https://patchnext.com/advisories/cve-2026-44572 (revision 2, source checked 26 Oct 2026, 12:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: next 16.2.5, 15.5.16. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm next: affected >= 12.2.0, < 15.5.16; >= 16.0.0, < 16.2.5; fixed in 16.2.5, 15.5.16

## Suggested inspection (read-only)
- `npm ls next --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on next.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3g8h-86w9-wvmq (OSV record GHSA-3g8h-86w9-wvmq lists affected ranges: npm next >=12.2.0 =16.0.0 <16.2.5 (fixed))
- Verified: https://github.com/advisories/GHSA-3g8h-86w9-wvmq (GitHub-reviewed advisory GHSA-3g8h-86w9-wvmq lists affected ranges: npm next >=12.2.0 =16.0.0 <16.2.5)

Commands are suggestions: review each one before running it.

Loading voting…